XL 2016 MOYENNE.SI avec des données non adjacentes

Mawie

XLDnaute Nouveau
Hello tout le monde :)

Je souhaite utiliser la fonction MOYENNE.SI, seulement je n'ai pas de plage de données simple : mes données sont éparpillées dans le document et je ne peux donc pas juste coulisser le curseur pour les selectionner.

Voici ce que donne mon essai :
1583841068511.png


J'ai automatiquement ce message d'erreur :
1583841087239.png


Est-il impossible de faire un moyenne qui inclue les données, uniquement si différentes de 0, dans un cas comme celui-ci où les cellules des données ne se suivent pas ?
Ou est-ce que quelque chose est incorrect dans ma formule ? Peut-être que je les sélectionne mal ?

Merci à tous pour votre temps :)
 
Solution
Bonjour Mawie,
Il y a erreur car cette syntaxe n'est pas acceptée.
Une méthode barbare si vous n'avez que quelques valeurs :
VB:
=SOMME(A11;B11;E11;H11;K11;)/(NB.SI(A11;"<>0")+NB.SI(B11;"<>0")+NB.SI(E11;"<>0")+NB.SI(H11;"<>0")+NB.SI(K11;"<>0"))

Statistiques des forums

Discussions
300 795
Messages
1 987 250
Membres
209 758
dernier inscrit
eguillet