Microsoft 365 Suivi clients consigner les évènements du suivi (calendrier)

mcfv

XLDnaute Junior
Supporter XLD
Bonjour à toute l'équipe

je mets une volonté de ouf a créer un calendrier d'événement pour le suivi des clients, et grâce à vous et vos conseils je prends plaisir à développer mes connaissances dans Excel ou power query MERCI.
mais malheureusement, je ne suis pas au top j'ai encore besoin de vous 🤩

je voudrais créer un calendrier ou des évènements seraient consignées à date, pour le suivi des réclamations ou autre. (macro évènementielle)
et avoir une vision sur 12 mois en naviguant de gauche à droite ou vice versa.

Option 1 (j'ai réalisé une vba qui ne fonctionne pas 😣)
- onglet "événement" je note les éléments qui seront repris sur le calendrier
- onglet "possibilité 1": lorsque je sélectionne une date les événements apparaissent (bémol avec cet matrice les événements sont visibles sur le jour sélectionné uniquement)

1695223062571.png



Option 2
-onglet "événement" je note les éléments qui seront repris sur le calendrier
- onglet "possibilité 2": permettant de naviguer de mois en mois et d'avoir une vision plus large (plus adapté à mon travail de suivi)


Espérant vous avoir traduit correctement mes besoins

je vous remercie d'avance pour vos lumières


ci-joint mon modeste fichier
 

Pièces jointes

  • Suivi Clients - Calendrier événement.xlsm
    37 KB · Affichages: 10
Solution
Bonjour mcfv, le forum,

Content que cela fonctionne maintenant.;)

Quels sont les critères de différenciation pour définir cette règle ?

Une Mise en Forme Conditionnelle peut faire le taf avec une formule de recherche d'un mot du style :
VB:
=NB.SI(B14;"*Facture*")>0
en vert, puis une autre en bleu :
Code:
=NB.SI(B14;"*Demande*")>0

Essaie avec cela sinon précise en peu plus.

A+
AL 22
Oui c'est une bonne solution avec le critère en début de description ca marche parfait
au final je pense que c'est un bon post (complet) qui pourra aider d'autre utilisateur du forum.

merci AL 22 pour la qualité des échanges

a bientôt car je vais certainement avoir d'autre sujet ;)

mcfv

XLDnaute Junior
Supporter XLD
Attends, ne t'en va pas tout de suite !

Testé sur 3 PC avec 3 versions d'Excel. RAS..., désolé ! Et tant que je ne peux reproduire le problème, je ne peux rien faire.
Question toute bête, as-tu activé les macros ?
Non je n'ai pas activé de macro !
Je ne serai pas faiee d'ailleurs ?
Mais oui c'est ça alors.
Tu accepte de me dire comment faire ?
Merci Al22
 

AL 22

XLDnaute Occasionnel
Re coucou,

Dans la copie d'écran de ton post initial (post #1) et dans la copie d'écran de la macro "Report" (post #13), on peut remarquer une icône qui est activée.
Cette icône correspond au "mode travail", c'est à dire que les macros sont désactivées. C'est ballot...
Il te suffit de cliquer dessus pour les activer. :)

1695325255992.png


1695325281991.png


En revanche, je ne vois pas l'onglet Développeur dans le ruban Excel. Va dans le menu Fichier du ruban, clique sur Options (en bas à gauche), clique sur Personnaliser le ruban et à droite coche Développeur puis valide par OK.

1695325379561.png


L'onglet développeur une fois dans le ruban te permettra d'avoir accès aux différentes options d'activation (Sécurité des macros)

1695325546501.png


Personnellement j'active tout, mais tu peux choisir différents niveaux de sécurité, à toi de voir.

1695325705022.png


Bon, teste le classeur et dis-moi si c'était cela.
À bientôt

AL 22
 

mcfv

XLDnaute Junior
Supporter XLD
Re coucou,

Dans la copie d'écran de ton post initial (post #1) et dans la copie d'écran de la macro "Report" (post #13), on peut remarquer une icône qui est activée.
Cette icône correspond au "mode travail", c'est à dire que les macros sont désactivées. C'est ballot...
Il te suffit de cliquer dessus pour les activer. :)

Regarde la pièce jointe 1179318

Regarde la pièce jointe 1179319

En revanche, je ne vois pas l'onglet Développeur dans le ruban Excel. Va dans le menu Fichier du ruban, clique sur Options (en bas à gauche), clique sur Personnaliser le ruban et à droite coche Développeur puis valide par OK.

Regarde la pièce jointe 1179320

L'onglet développeur une fois dans le ruban te permettra d'avoir accès aux différentes options d'activation (Sécurité des macros)

Regarde la pièce jointe 1179321

Personnellement j'active tout, mais tu peux choisir différents niveaux de sécurité, à toi de voir.

Regarde la pièce jointe 1179323

Bon, teste le classeur et dis-moi si c'était cela.
À bientôt

AL 22
Bonjour AL 22

Suuuper!!!! ca marche, merci pour ton soutien, et d'avoir pris le temps de m'accompagner sur ce post.
car souvent ca tiens à rien du tout.

je te souhaite une très belle journée.
a bientot
 

mcfv

XLDnaute Junior
Supporter XLD
Bonjour a tous,

il existe aussi la possibilité de pivot avec resutat texte... Comme quoi Query peut tout faire.
Et ceci reste donc compatible SharePoint...

Regarde la pièce jointe 1179308

A+
Merinos
Bonjour Merinos
merci pour ton intervention, effectivement c'est intéressant de savoir que nous pouvons également le travailler su query. (je garde cet exemple en tête)
bonne journée. ;)
 

AL 22

XLDnaute Occasionnel
Bonjour mcfv, le forum,

Content que cela fonctionne maintenant.;)

Quels sont les critères de différenciation pour définir cette règle ?

Une Mise en Forme Conditionnelle peut faire le taf avec une formule de recherche d'un mot du style :
VB:
=NB.SI(B14;"*Facture*")>0
en vert, puis une autre en bleu :
Code:
=NB.SI(B14;"*Demande*")>0

Essaie avec cela sinon précise en peu plus.

A+
AL 22
 

mcfv

XLDnaute Junior
Supporter XLD
Bonjour mcfv, le forum,

Content que cela fonctionne maintenant.;)

Quels sont les critères de différenciation pour définir cette règle ?

Une Mise en Forme Conditionnelle peut faire le taf avec une formule de recherche d'un mot du style :
VB:
=NB.SI(B14;"*Facture*")>0
en vert, puis une autre en bleu :
Code:
=NB.SI(B14;"*Demande*")>0

Essaie avec cela sinon précise en peu plus.

A+
AL 22
Oui c'est une bonne solution avec le critère en début de description ca marche parfait
au final je pense que c'est un bon post (complet) qui pourra aider d'autre utilisateur du forum.

merci AL 22 pour la qualité des échanges

a bientôt car je vais certainement avoir d'autre sujet ;)
 

Discussions similaires

Statistiques des forums

Discussions
313 315
Messages
2 097 056
Membres
106 822
dernier inscrit
jolost2