Mes heures de travails

KevG

XLDnaute Nouveau
Bonjour,

J'aimerais pouvoir utiliser le logiciel Excel 2003 pour inscrire mes heures de travail que j'ai effectuées.

Dans celui-ci, si possible, j'aimerais qu'à l'intérieur se retrouve ces informations:


- Date (ex: Lundi 1 juillet 2010)
- Heure de début
- Heure de départ
- Heures effectuées (avec exemple: du 1 juillet 17:30 au 2 juillet 1:00 (AM))
- Salaire gagné durant cette journée
- Total heures d'effectuées durant: la semaine et le mois
- Total d'$ gagné durant: la semaine et le mois


Ce classeur serait pour garder mes heures de travail effectuées et pour voir le salaire gagné.
Dans ce classeur les onglets représenteront l'endroit ou le travail a été fait. (L'employeur ou le nom de l'entreprise, par exemple)

Donc, dans chaque onglet je devrais retrouver une année entière.
-> Alors je devrai avoir "un macros" où je pourrai choisir l'année courante ...


Mon problème, est que je ne sait aucunement comment organiser mon tableau pour avoir toutes ces informations et je n'est pas beaucoup de connaissances ... :\

J'ai téléchargé divers classeurs excel de votre site, mais ils étaient .. trop compliqués.


Je suis prêt à investir du temps ou sinon, vous pouvez m'aligner vers quelque chose présent sur votre site.


Merci beaucoup :rolleyes:

Cordialement,
KevG:eek:
 

jeanpierre

Nous a quitté
Repose en paix
Re : Mes heures de travails

Bonsoir KevG, et Bienvenue sur le forum,

Tu as trouvé des choses "trop compliquées" mais ce que tu demandes n'est pas simple non plus... on risque de tourner en rond longtemps....

Dépose nous un fichier qui représente la chose telle que tu la vois... Peut-être pourrons nous te guider.

Bonne soirée.

Jean-Pierre
 

KevG

XLDnaute Nouveau
Re : Mes heures de travails

Bonjour,

merci pour l'accueil :p

Bon ...
Je ne sais pas si vous vouliez que je vous joint un fichier que j'ai fais et dont il reste des modifications ... Donc, j'ai fais un classeur avec les informations que j'aimerais ... Regardez-le et dites-moi si vous comprenez ! :eek:

Également, je vous joint des fichiers que j'ai vu sur votre site et qui pourrait ressembler à ce que je recherche, MAIS qui n'est pas ce que je recherche ...

Le fichier avec ce que j'aimerais avoir se nomme "Heures effectues.xls".


Merci pour votre future aide ;)
 

Pièces jointes

  • Heures effectuées.xls
    17 KB · Affichages: 56
  • Fiche_d_heures_neg_mod.zip
    22 KB · Affichages: 29
  • Copie de des Heures.zip
    28.7 KB · Affichages: 35
  • Fiche_d_heures_neg_mod.zip
    22 KB · Affichages: 28
  • Copie de des Heures.zip
    28.7 KB · Affichages: 34
  • Fiche_d_heures_neg_mod.zip
    22 KB · Affichages: 32
  • Copie de des Heures.zip
    28.7 KB · Affichages: 32

Tibo

XLDnaute Barbatruc
Re : Mes heures de travails

Bonjour,

Quelques formules de base :


en D16 :

Code:
=C16-B16


Si tu saisis tes heures au format heure d'Excel, en F16 :

Code:
=D16*$I$27*24


en J40, pour le récapitulatif :

Code:
=SOMMEPROD((TEXTE($A15:$A250;"mmmmaaaa")=$I40&$I$39)*1;D15:D250)


sa petite soeur en L40 :

Code:
=SOMMEPROD((TEXTE($A15:$A250;"mmmmaaaa")=$I40&$I$39)*1;F15:F250)


Formules à recopier vers le bas

Je te laisse essayer.

Sinon, il faut quand même avoir une idée plus précise de ce que tu souhaites. Le Forum est là pour t'aider à réaliser ce souhait.

@+
 

KevG

XLDnaute Nouveau
Re : Mes heures de travails

Tout ça commence à être bien intéressant :)))

Mais, quelque chose ...

Il m'arrive de, par exemple, de travailler du 1er juillet 17h30 au 2 juillet 1h AM.

Pour les heures travaillées, excel m'indique une erreur :confused: -> #### ..

Alors qu'il devrait m'indiquer 7:30 ....


Puis, il me restera à trouver comment faire quelque chose de joli ...
Des suggestions ? :p
Merci
Voilà ;)
 

KevG

XLDnaute Nouveau
Re : Mes heures de travails

Nouvelle petite question:


Par exemple, dans mon classeur, j'ai diverses données ... un peu inutiles.

Exemple:
01 juillet 2010 17h30 18h30 01h00 20,00 $ --> J'ai souvent des zéros inutiles.


Également, pendant mes recherches, par hasard, j'avais vu une page qui expliquait comment ne pas afficher des données ...

Je cite mon classeur: :p

Samedi 17 juillet 2010 00h00 0,00 $
Dimanche 18 juillet 2010 00h00 0,00 $

Comment pourrais-je faire pour ne pas afficher ces informations, lorsque c'est seulement que des zéros ?
Et que lorsqu'il y aura un salaire ou des heures, cela s'affiche ?


Merci à tous pour
votre future aide !

Cordialement,
KevG
 

KevG

XLDnaute Nouveau
Re : Mes heures de travails

Bonjour Hoerwind,

Merci pour votre réponse, avec cela, j'ai réajusté tous les détails qui me tracassaient ! :rolleyes::D

Autre, et dernier (j'espère) détail:
Regardez mon classeur, sur la droite vous verrez "Grand total".
J'aimerais pouvoir grossir le caractère (je suis présentement à 10).
Le problème, est que si je grossi seulement ces deux mots, cela grossi également toute la ligne :eek: ... Normal, mais j'aimerais savoir si je pourrais augmenter la grosseur de caractère pour seulement "Grand total" ?

Merci pour votre précieuse aide,
KevG
 

Tibo

XLDnaute Barbatruc
Re : Mes heures de travails

Bonjour,

Sur le dernier fichier joint, "Grand total" est en police taille 14.

Le fait d'augmenter la taille de la police du texte d'une cellule peut effectivement avoir un impact sur la hauteur de la ligne.

Ici, avec une taille 14, tu peux ramener la hauteur de ta ligne à la même hauteur que tes autres lignes. Le texte "Grand total" reste lisible.

Si pas ça, reviens avec plus de précisions.

@+
 

hoerwind

XLDnaute Barbatruc
Re : Mes heures de travails

Re,

Je vais te conseiller quelque chose que je n'aime pas faire !
Supprimes les espaces devant Grand total
Sélectionne I30:J31
Clique sur l'icône de la barre d'outils Format : Fusionner et centrer.
Centre également à la verticale
Chez moi je puis aller jusqu'à une police de 28.

Edition : salut Tibo, pas vu !
 

KevG

XLDnaute Nouveau
Re : Mes heures de travails

Bonjour à tous !

Je suis vraiment désolé, cela fait énormément de temps que je ne suis pas passé. J'ai fais le ménage dans ma boîte de réception et j'ai vu le message que j'avais mis de côté. :rolleyes:

Donc, je viens redonner de mes nouvelles.
Finalement, j'ai réussi à avoir ce que je voulais !

Un gros merci à tous ! :D
 

Discussions similaires

Réponses
5
Affichages
745

Membres actuellement en ligne

Aucun membre en ligne actuellement.

Statistiques des forums

Discussions
312 827
Messages
2 092 557
Membres
105 451
dernier inscrit
mariane_lp