XL 2010 Croix

celine123

XLDnaute Junior
bonjour a tous,
j'ai un tableau dans lequel j’aimerai mettre des X de façon aléatoire au nombre de 3 par ligne et si la zone (e) est cocher, j'aimerai que des choix libre (sans croix) s’inscrive (la lettre correspondante) de façon aléatoire dans la colonne aléatoire du tableau
 

Pièces jointes

  • aléatoire.xlsx
    11.1 KB · Affichages: 26

Modeste geedee

XLDnaute Barbatruc
Bonsour®
bonjour a tous,
j'ai un tableau dans lequel j’aimerai mettre des X de façon aléatoire au nombre de 3 par ligne et si la zone (e) est cocher, j'aimerai que des choix libre (sans croix) s’inscrive (la lettre correspondante) de façon aléatoire dans la colonne aléatoire du tableau
upload_2016-12-7_16-14-6.png
00
 

Pièces jointes

  • aléatoire.xlsx
    17.9 KB · Affichages: 36

celine123

XLDnaute Junior
c'est ça mais j'ai juste une petite correction a te demander
Pour exemple de la ligne 2 de la photo que tu as posté dans aléatoire c est sélectionné alors qu'il est coché il faudrait que seul ceux non coché peuvent apparaître dans la colonne aléatoire (pour la 2 éme ligne en exemple le choix pouvais être b ou d)
 

Modeste geedee

XLDnaute Barbatruc
Bonsour®
c'est ça mais j'ai juste une petite correction a te demander
Pour exemple de la ligne 2 de la photo que tu as posté dans aléatoire c est sélectionné alors qu'il est coché il faudrait que seul ceux non coché peuvent apparaître dans la colonne aléatoire (pour la 2 éme ligne en exemple le choix pouvais être b ou d)
corriger N9 par :
=SI(M9="X";INDEX($C$8:$G$8;EQUIV(GRANDE.VALEUR($C9:$G9;4);$C9:$G9;0));"")
upload_2016-12-7_20-1-6.png
.
 

celine123

XLDnaute Junior
Nickel parfait un grand merci à toi
Pourrais-je te demander une dernière chose

serait il possible (c'est une autre demande) sur la même base pour la colonne aléatoire de sélectionner de façon aléatoire une des 2 lettre non cocher pour toutes les lignes
exemple: lgn1 c ou d
lgn2 c ou a
lgn 3 d ou e .... mais pour toutes les lignes
 

Modeste geedee

XLDnaute Barbatruc
Bonsour®
Nickel parfait un grand merci à toi
Pourrais-je te demander une dernière chose

serait il possible (c'est une autre demande) sur la même base pour la colonne aléatoire de sélectionner de façon aléatoire une des 2 lettre non cocher pour toutes les lignes
exemple: lgn1 c ou d
lgn2 c ou a
lgn 3 d ou e .... mais pour toutes les lignes
il suffit dans ce cas de supprimer la condition sur la colonne M .
la formule en N9 devient alors :
=INDEX($C$8:$G$8;EQUIV(GRANDE.VALEUR($C9:$G9;4);$C9:$G9;0))
 

Discussions similaires

Réponses
10
Affichages
410
Réponses
24
Affichages
598
  • Question
XL pour MAC mise en forme
Réponses
2
Affichages
279

Statistiques des forums

Discussions
312 854
Messages
2 092 830
Membres
105 540
dernier inscrit
missmel59