XL 2016 Tableau de synthèse (INDEX EQUIV ?)

nvsk89

XLDnaute Nouveau
Bonjour à tous,

Je sollicite votre aide pour une manipulation qui est certainement simple, mais qui ne l'est pas pour moi. J'ai une feuille dans laquelle il y a un certain nombre de noms (Pierre, Paul, etc.) auxquels sont associés deux lignes avec des fruits et des nombres de fruits (Feuil1 dans mon fichier). Le problème est que les fruits ne sont pas tous traités dans le même ordre, et je voudrais donc parvenir à faire une synthèse avec le nombre de fruits par personne (Feuil2).

EDIT : je pourrais bien sur le faire à la main dans le fichier joint, mais en réalité le fichier sur lequel je travaille comporte 900 noms, ce qui m'oblige à trouver une solution automatisée.

Merci mille fois, d'avance, pour votre aide si vous pouvez me débloquer !

nvsk
 

Pièces jointes

  • exemplefruits.xlsx
    10.6 KB · Affichages: 6
Dernière édition:

job75

XLDnaute Barbatruc
Bonsoir nvsk89, Hasco,

Une autre formule en B2 :
VB:
=SOMMEPROD((SUPPRESPACE(Feuil1!$B$1:$E$17)=SUPPRESPACE(B$1))*(Feuil1!$A$1:$A$17=$A2);Feuil1!$B$2:$E$18)
Les SUPPRESPACE neutralisent les espaces superflus (6 en Feuil1 et 1 en Feuil2).

A+
 

Pièces jointes

  • exemplefruits(1).xlsx
    12.2 KB · Affichages: 1

Statistiques des forums

Discussions
300 795
Messages
1 987 250
Membres
209 755
dernier inscrit
bla89