XL 2019 Statistique pour le Tableau de bord

Htracy

XLDnaute Nouveau
Bonjour la grande famille,

Puis-je avoir votre aide s'il-vous-plaît ?

Avec le tableau ci-joint : Générer des formules pour résoudre les problèmes des tableaux à droite (TAB1 et TAB2) en partant sur la liste des cours sur la ligne 4.
TAB1 : Mettez les 5 premiers cours qui ont des vides (les cours sont sur la ligne 4 à partir des cellules D4 jusqu'à T4) et mettez les résultats dans le ce tableau avec les nombres des vides (sur la colonne AA)
TAB2 : Mettez les 5 premiers cours qui ont des échecs (dont les résultats sont des côtes en rouge) ou carrement en dessous de leurs moyennes et le résutats seront affichés dans TAB2.

Je suis un peu bloqué pour cette résolution.
 

Pièces jointes

  • Cotation_Stata.xlsx
    13.6 KB · Affichages: 7
Solution
Bonjour Htracy,
Un essai en PJ avec deux lignes supplémentaires :
VB:
Nbre absents :
=NB.SI(D6:D17;"")+COLONNE()/1000000
Nbre échecs :
=NB.SI(D6:D17;"<"&D5/2)+COLONNE()/1000000
et
Code:
Nbre vides :
=SI(GRANDE.VALEUR($D$19:$T$19;Y6)<1;"";GRANDE.VALEUR($D$19:$T$19;Y6))
Nom du cours :
=SI(Tableau1[[#Cette ligne];[Nombre des vides ]]="";"";INDEX($D$4:$T$4;EQUIV(Tableau1[[#Cette ligne];[Nombre des vides ]];$D$19:$T$19;0)))

Nbre échecs :
=SI(GRANDE.VALEUR($D$20:$T$20;Y15)<1;"";GRANDE.VALEUR($D$20:$T$20;Y15))
Nom du cours :
=SI(Tableau2[[#Cette ligne];[Nombres d''échecs (en dessous de la moyenne de chaque cours)]]="";"";INDEX($D$4:$T$4;EQUIV(Tableau2[[#Cette ligne];[Nombres d''échecs (en dessous de la moyenne de chaque...

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Htracy,
Un essai en PJ avec deux lignes supplémentaires :
VB:
Nbre absents :
=NB.SI(D6:D17;"")+COLONNE()/1000000
Nbre échecs :
=NB.SI(D6:D17;"<"&D5/2)+COLONNE()/1000000
et
Code:
Nbre vides :
=SI(GRANDE.VALEUR($D$19:$T$19;Y6)<1;"";GRANDE.VALEUR($D$19:$T$19;Y6))
Nom du cours :
=SI(Tableau1[[#Cette ligne];[Nombre des vides ]]="";"";INDEX($D$4:$T$4;EQUIV(Tableau1[[#Cette ligne];[Nombre des vides ]];$D$19:$T$19;0)))

Nbre échecs :
=SI(GRANDE.VALEUR($D$20:$T$20;Y15)<1;"";GRANDE.VALEUR($D$20:$T$20;Y15))
Nom du cours :
=SI(Tableau2[[#Cette ligne];[Nombres d''échecs (en dessous de la moyenne de chaque cours)]]="";"";INDEX($D$4:$T$4;EQUIV(Tableau2[[#Cette ligne];[Nombres d''échecs (en dessous de la moyenne de chaque cours)]];$D$20:$T$20;0)))
 

Pièces jointes

  • Cotation_Stata.xlsx
    16.5 KB · Affichages: 13

Discussions similaires

Réponses
0
Affichages
319

Statistiques des forums

Discussions
313 286
Messages
2 096 820
Membres
106 755
dernier inscrit
riviere gabriel