XL 2010 Somme valeur gauche et droite

YanCad

XLDnaute Nouveau
Bonjour,

Je cherche à additionner les valeurs d'une colonne qui ont du texte et des chiffre dans la même cellule.
J'ai un début de formule mais elle ne fonctionne pas.
Merci de m'aider

=somme.si(Calendrier!AF3:AF33;"DSM";DROITE(Calendrier!AF3:AF33;1))
ou
=SOMMEPROD((GAUCHE(Calendrier!AF3:AF33;3)="DSM");(DROITE(Calendrier!AF3:AF33;1)))
 

JHA

XLDnaute Barbatruc
Bonjour à tous,


Avec un fichier exemple cela serait plus sympa, voir exemple joint.
Peux-tu essayer avec la matricielle suivante (validation avec CTRL+Maj+Entrée), les plages sont à adapter.
Code:
=SOMME(SI((GAUCHE($A$1:$I$1;3)="DSM")*(ESTNUM(DROITE($A$1:$I$1;1)*1));DROITE($A$1:$I$1;1)*1))

JHA
 

Pièces jointes

  • essai Yancad.xlsx
    8.5 KB · Affichages: 38

Discussions similaires

Réponses
2
Affichages
288

Statistiques des forums

Discussions
312 911
Messages
2 093 509
Membres
105 745
dernier inscrit
gilou7025