XL 2013 Incrémenter si condition validée et si entre 2 dates

Akyrah

XLDnaute Nouveau
Bonjour,

Je viens demander de l'aide pour une formule me permettant d'incrémenter +1 dans la colonne E à chaque entrée si une condition est remplie et si cette condition est comprise entre 2 dates.
Voici déjà une image pour illustrer ma demande, et le fichier Excel en PJ.

Ici exemple : si le CODE 555 est présent en colonne B et s'il est compris entre le 01/01/2024 et le 10/01/2024 dans la colonne D selon les entrées variables en G2 et H2.
Que cela numérote de 1 à 3 comme ici selon les critères choisis.

1714384296398.png


Merci d'avance pour l'étude de ma demande et l'aide que vous voudrez bien m'apporter.
 

Pièces jointes

  • Incrémenter si conditions multiples.xlsx
    10.4 KB · Affichages: 2

JHA

XLDnaute Barbatruc
Bonjour à tous,

Un essai avec une MFC
VB:
=ESTNUM(EQUIV(LIGNE()-1;($B$2:$B$10=$I$2)*($D$2:$D$10>=$G$2)*($D$2:$D$10<=$H$2)*(LIGNE($B$2:$B$10)-1);0))

JHA
 

Pièces jointes

  • Incrémenter si conditions multiples.xlsx
    11.6 KB · Affichages: 2

Akyrah

XLDnaute Nouveau
Bonjour à tous,

Un essai avec une MFC
VB:
=ESTNUM(EQUIV(LIGNE()-1;($B$2:$B$10=$I$2)*($D$2:$D$10>=$G$2)*($D$2:$D$10<=$H$2)*(LIGNE($B$2:$B$10)-1);0))

JHA

Bonjour et merci JHA,

Cependant, cela ne répond pas à ma demande, j'en suis désolée.
Je souhaite que la colonne E se remplisse automatiquement, en numérotant de 1 à ... selon les critères demandés.

Selon mon exemple : si le CODE 555 est présent en colonne B et s'il est compris entre le 01/01/2024 et le 10/01/2024 dans la colonne D selon les entrées variables en G2 et H2, que la colonne E me mette un numéro incrémenté pour chaque entrée validée.
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Peut-être:
VB:
=SI((D$2:D2>=$G$2)*(D$2:D2<=$H$2);NB.SI.ENS(B$2:B2;B2;D$2:D2;">="&$G$2;D$2:D2;"<="&$H$2);"")

JHA
 

Pièces jointes

  • Incrémenter si conditions multiples.xlsx
    11.8 KB · Affichages: 5

Akyrah

XLDnaute Nouveau
Bonjour à tous,

Peut-être:
VB:
=SI((D$2:D2>=$G$2)*(D$2:D2<=$H$2);NB.SI.ENS(B$2:B2;B2;D$2:D2;">="&$G$2;D$2:D2;"<="&$H$2);"")

JHA


Bonjour à tous et bonjour JHA,

Cela correspond parfaitement !
Je te remercie pour cette réponse très rapide.
La formule est superbe, si si !
Elle parait si "facile" une fois sous les yeux et j'espère qu'elle pourra servir à d'autres.

Bonne journée,
 

Discussions similaires

Réponses
15
Affichages
682
Réponses
9
Affichages
663

Membres actuellement en ligne

Aucun membre en ligne actuellement.

Statistiques des forums

Discussions
313 271
Messages
2 096 724
Membres
106 720
dernier inscrit
Alain EDZOA