Google Sheets ARRAYFORMULA pour identifier les jours fériés

pierrrot

XLDnaute Nouveau
Bonjour à toutes et à tous,

Dans Google Sheets, je voudrais afficher "Jour férié" en face des dates concernées, à partir d'un tableau des jours fériés qui est dans un autre onglet.
Cliquez ici pour voir l'exemple

1716984549597.png


Dans la colonne C "Résultat attendu", j'ai mis une formule à chaque ligne qui semble fonctionner.
Code:
=SI(NON(ESTERREUR(RECHERCHEV(A2;INDIRECT("'Fériés'!" & SIERREUR(ADRESSE(2;EQUIV(ANNEE(A2);'Fériés'!$B$1:$1)+1);"") & ":" & SIERREUR(GAUCHE(ADRESSE(2;EQUIV(ANNEE(A2);'Fériés'!$B$1:$1)+1);3);"") & "14");1;FAUX)));"Jour férié";"")

Mais quand j'essaie de traduire la même formule avec ARRAYFORMULA dans la colonne B "Est un jour férié", ça ne fonctionne pas : seuls les jours fériés de l'année correspondant à la ligne 2 ressortent.
Code:
={"Est un jour férié";ARRAYFORMULA(SI(NON(ESTERREUR(RECHERCHEV(A2:A;INDIRECT("'Fériés'!" & SIERREUR(ADRESSE(2;EQUIV(ANNEE(A2:A);'Fériés'!$B$1:$1)+1);"") & ":" & SIERREUR(GAUCHE(ADRESSE(2;EQUIV(ANNEE(A2:A);'Fériés'!$B$1:$1)+1);3);"") & "14");1;FAUX)));"Jour férié";""))}

Auriez-vous une solution ?

Merci beaucoup d'avance à celles et ceux qui se pencheront sur mon problème.
Bonne journée
Pierrrot
 
Dernière édition:

Discussions similaires

Statistiques des forums

Discussions
313 224
Messages
2 096 338
Membres
106 572
dernier inscrit
JM04082023!