Tri de (très) nombreuses données

narfazel

XLDnaute Nouveau
Bonjour,

J'ai un problème et peu de temps pour le résoudre...

Il s'agit d'une liste (70000 lignes...) avec deux colonnes:
- la date et l'heure (chaque 5 min)
- la hauteur d'eau

Mon but est de compter pour chaque jour puis pour chaque mois, le nombre de minutes pendant lesquelles la hauteur d'eau est supérieure à 2.9m.

J'ai déjà essayé d'utiliser la fonction sous-totaux et j'obtiens les résultats pour chaque jour, seulement, je voudrais mettre automatiquement en forme ces données dans des tableaux du genre:
Janvier: 1 2 etc... TOTAL Janvier
500min 400min XX min

Y-a-t-il donc une formule qui pourrait me permettre de faire cela?
J'ai mis un bout du fichier en pièce jointe (le fichier entier est trop gros)


Merci d'avance pour votre aide!
 

Pièces jointes

  • marée forum LT.xls
    31 KB · Affichages: 50
  • marée forum LT.xls
    31 KB · Affichages: 49
  • marée forum LT.xls
    31 KB · Affichages: 49

CISCO

XLDnaute Barbatruc
Re : Tri de (très) nombreuses données

Bonsoir

Peut être avec quelque chose comme ça... Il te faudra peut être modifier le premier < en <=... A toi de voir.

@ plus
 

Pièces jointes

  • marée forum LT.xls
    44.5 KB · Affichages: 40
  • marée forum LT.xls
    44.5 KB · Affichages: 45
  • marée forum LT.xls
    44.5 KB · Affichages: 46
Dernière édition:

Victor21

XLDnaute Barbatruc
Re : Tri de (très) nombreuses données

Bonsoir, narfazel, et bienvenue sur XLD

Pour le nombre de minutes pour chaque jour, essayez en F8, à recopier vers le bas :
=SOMMEPROD((ENT($A$2:$A$318)=D8)*($B$2:$B$318>2.9))*5
($318 à adapter selon vos données complètes.)
Pour obtenir le total mensuel, vous pouvez soit adapter la formule, soit additionner les résultats quotidiens.
Si vous devez travailler ultérieurement sur cette feulle, je vous conseille de copier-coller les valeurs obtenues,les multiples sommeprod() risquant de consommer beaucoup de ressources.
A noter que vous n'obtiendrez pas une durée (hh:mm),mais un nombre de minutes.
:)
 

Misange

XLDnaute Barbatruc
Re : Tri de (très) nombreuses données

Bonjour, hello Patrick et Cisco
une proposition avec une colonne supplémentaire qui teste juste si la hauteur d'eau est supérieure à 2.9 puis un TCD. Ca te permet de regrouper en un clic par jour, mois année...
 

Pièces jointes

  • Copie de marée forum LT-1.xls
    86.5 KB · Affichages: 37

Discussions similaires

Membres actuellement en ligne

Aucun membre en ligne actuellement.

Statistiques des forums

Discussions
312 827
Messages
2 092 557
Membres
105 451
dernier inscrit
mariane_lp