XL 2016 retourner des dates à parti d'un tableau en indiquant le mois

Akafal

XLDnaute Nouveau
j'ai un fichier comportant deux feuilles
la première contient un tableau avec des informations, semaines, mois, jours de la semaine (ci joint le fichier)
sur la seconde feuille, je souhaiterai avoir le premier lundi et le premier vendredi en indiquant le mois
je vous remercie pour cotre assistance
 

Pièces jointes

  • fichier pour forum excel.xlsx
    23.2 KB · Affichages: 10

Akafal

XLDnaute Nouveau
merci Sylvanu
seulement que cette solution a modifié les données de mon tableau.
dans mon tableau il y a plusieurs fois le meme mois.
je vous renvoie le fichier avec plus de précisions.
il ne s'agit pas de trouver seulement le premier lundi ou vendredi des mois.
mais lorsque j'indique le mois de mon choix suivant mon tableau, que la formule me retourne le premier lundi et le premier mercredi correspondant.
je précise que je ne sais pas bien travaillé en VBA
je vous remercie
 

Pièces jointes

  • fichier 2 pour forum excel.xlsx
    24 KB · Affichages: 2

Akafal

XLDnaute Nouveau
Bonjour Akafal,
Un essai en PJ avec :
VB:
=C3+CHOISIR(JOURSEM(C3);1;0;6;5;4;3;2)
et
Code:
=SI(JOUR(D3)<4;D3+4;D3-3)
merci Sylvanu
seulement que cette solution a modifié les données de mon tableau.
dans mon tableau il y a plusieurs fois le meme mois.
je vous renvoie le fichier avec plus de précisions.
il ne s'agit pas de trouver seulement le premier lundi ou vendredi des mois.
mais lorsque j'indique le mois de mon choix suivant mon tableau, que la formule me retourne le premier lundi et le premier vendredi correspondant.
je précise que je ne sais pas bien travaillé en VBA
je vous remercie
Bonjour à tous,

Cela reste le même

JHA
Bonsoir JHA
je constate que dans votre fichier joint la date du vendredi retournée est inférieure à la date du lundi. il y a un problème non? cela devait être le contraire
merci
 

Pièces jointes

  • fichier 2 pour forum excel.xlsx
    24 KB · Affichages: 1

JHA

XLDnaute Barbatruc
Bonjour à tous,

Et non, pas de soucis de formule, tu as demandé le premier vendredi du mois donc pour mars 2022 c'est le 04/03.
Concernant le lundi, le premier du mois est le 07/03.
Autrement il faut demander le premier vendredi après le premier lundi soit premier lundi +4 jours.

JHA
 

Discussions similaires

Réponses
8
Affichages
239

Statistiques des forums

Discussions
312 875
Messages
2 093 144
Membres
105 638
dernier inscrit
cordier