XL 2016 recherchev + cumul des quantites trouvees

fantasio

XLDnaute Nouveau
Bonjour

je souhaite faire une recherche verticale et cumuler dans une même cellule les résulatats identiques

EX rechercheV colonne A - valeur X
- afficher le résultat de la colonne B dans cellule C1
Ca je sais faire

Par contre
si j'ai plusieurs fois la valeur X dans ma colonne A
Comment je peux faire pour que toutes les valeurs trouvées en colonne B soit cumulées en C1

Merci pour votre aide

Salutations
 

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Fantasio,
Sans fichier test, c'est un peu au pif. Testez :
VB:
=SOMME.SI(A:A;"X";B:B)
Et si vous avez plus de critères :
 

fantasio

XLDnaute Nouveau
Bonjour à vous 2

je vous joins mon fichier de base et mon fichier à completer
sur mon fichier à completer
je souhaite que quand le mot en B4 est trouvé dans le fichier de base -
il s'affiche en A4 - la somme de toutes les valeurs F

Dans mon exemple,
en A10 = 20 (somme lignes en jaune sur fichier de base)
en A13 = 26 (somme lignes en vert sur fichier de base)

Merci d'avance pour votre aide

Sltts
 

Pièces jointes

  • FICHIER A COMPLETER.xlsx
    49.3 KB · Affichages: 5
  • fichier base.xlsx
    17.3 KB · Affichages: 4

sylvanu

XLDnaute Barbatruc
Supporter XLD
Re Fantasio, bonjour Nat,
Un essai en PJ, j'ai tout mis dans fichier base pour faire simple, avec :
VB:
=SOMME.SI(A:A;P2;F:F)
Dans votre message A10 veut dire Q1GALA100 et A13 Q1GALA113 ?
Si c'est ça alors livrez aussi le traducteur. :) mais dans ce cas les valeurs sont correctes.
 

Pièces jointes

  • fichier base.xlsx
    17.5 KB · Affichages: 7

fantasio

XLDnaute Nouveau
Bonjour

OK donc je suis obligé de passer par un tableau intermédiare à faire dans le fichier d'origine (ce que tu m'as créé) avant de recopier les resultats dans mon tableau intitulé "fichier à compléter".
On ne peut pas directement retranscrire l'info si je comprends bien ?
en tous cas c'est parfait, tu m'as me faire gagner un temps précieux quand j'aurais mis ca en place
👍
un grand merci
 

Discussions similaires

Statistiques des forums

Discussions
313 198
Messages
2 096 142
Membres
106 505
dernier inscrit
ngomez