XL 2019 recherche code, intitulé et prix à partir d une base de données

cavenagoal

XLDnaute Nouveau
Bonjour,
Je cherche une formule qui me permet de retrouver un produit via son code à 13 chiffres. L'ensemble des codes (environ 13 000) figure dans la colonne D du fichier base de données.
Lorsque je rentre le code dans la colonne B du fichier calcul, je voudrais que le nom du produit (colonne F du fichier base de données) apparaisse dans la colonne C ainsi que son prix (colonne H du fichier base de données) dans la colonne E.
Pouvez vous m'aider SVP ?

Merci
 

Pièces jointes

  • calcul forum excel.xlsx
    10.4 KB · Affichages: 6
  • base de données.xlsx
    11.5 KB · Affichages: 6

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonsoir Cavenagoal,
Un essai en PJ avec :
VB:
=SIERREUR(RECHERCHEV(B2;'[base de données.xlsx]Feuil1'!$D:$I;3;FAUX);"")
et
=SIERREUR(RECHERCHEV(B2;'[base de données.xlsx]Feuil1'!$D:$I;5;FAUX);"")
Dans la BDD, mettez les colonnes D et e en format Nombre, ce sera plus lisible.
 

Pièces jointes

  • calcul forum excel (5).xlsx
    14.1 KB · Affichages: 6

Discussions similaires

  • Résolu(e)
Microsoft 365 Tri et Import
Réponses
4
Affichages
265

Statistiques des forums

Discussions
312 922
Messages
2 093 658
Membres
105 778
dernier inscrit
Ricky22