problème avec formule matricielle

beamon

XLDnaute Nouveau
Bonjour,

voici une petite table:

a 1
z 2
a 3
r 4

Je voudrais compter le nombre de chiffres pour la valeur "a" de la 1è colonne. Je sais qu'il y a plus simple (NB.SI), mais j'expérimente avec les formules matricielles. J'ai utilisé deux formules qui devraient donner la même chose:

NB((A1:A4="a")*(B1:B4)) -> donne 4 !?!
NB(SI(A1:A4="a";B1:B4)) -> donne 2

(J'ai essayé les deux façons avec SOMME et toutes les deux donne 4). Pourquoi est-ce que la 1è formule ne donne pas le résultat correct?

Merci
beamon
 

Odesta

XLDnaute Impliqué
Re : problème avec formule matricielle

Bonjour

je vais tenter une petite explication du pourquoi :
La fonction NB donne le nombre de "nombre"
ex : =nb("AA";1;0) renvoie 2
Dans votre première matrice, vous renvoyez à NB la matrice (1;0;3;0) soient 4 nombres, puisque vous faite la multiplication de valeurs booleennes par une matrice remplie de nombre (VRAI; FAUX; VRAI; FAUX) * (1;2;3;4) => (1;0;3;0)
Dans le deuxième cas, vous renvoyer à la fois les valeurs boleennes pour le "faux" puisque par défaut vous n'avez rien indiqué dans le si, et les valeurs contenues dans [B1:B4] pour le "Vrai" ce qui donne (1;FAUX;3;FAUX) soient : 2 nombres.


J'espère avoir été clair.

Cordialement
Olivier
 

2passage

XLDnaute Impliqué
Re : problème avec formule matricielle

Bonjour,

Pour apporter un petit plus, on peut également compter les valeurs avec une formule matricielle à base de somme. Cette formule répond à l'exemple :
Code:
=SOMME((A3:A6="a")*1)
++
 

Discussions similaires

Statistiques des forums

Discussions
312 920
Messages
2 093 641
Membres
105 772
dernier inscrit
Momzo