XL 2019 problèmes avec une formule SOMME SI INDEX

vincentast

XLDnaute Junior
Bonjour,

J'ai sollicité hier de l'aide pour une création de deux formules, un membre du forum m'a gentiment aidé en me les créant, par contre une ne fonctionne pas et je ne comprends pas pourquoi; Je vous passe la formule

=SOMME(SI(INDEX(Calendrier!$F$7:$AU$31;EQUIV(Donnee!$A4;Calendrier!$A$7:$A$31;0);)="CP";1;0))

je voulais que dans mon fichier (voir piece jointe ) dans la cellule O4 de l'onglet"Donnee" calcul le nombre de cellule qui sont indiquées "CP" de la selection F7:AU287 de l'onglet"Calendrier" et comme référence la cellule A4 de l'onglet "Donnee"

merci beaucoup pour votre aide

vincent
 

Pièces jointes

  • tableau excel downldoad.xlsx
    164.2 KB · Affichages: 1

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Vincentast,
Suivant votre version d'XL votre formule matricielle doit être validée par Maj+Ctrl+Entrée ou non.
Par ex sous 2007 elle doit être validée comme matricielle et elle marche correctement.
1701003424521.png
 

Pièces jointes

  • tableau excel downldoad.xlsx
    175.8 KB · Affichages: 2

vincentast

XLDnaute Junior
Re,
Cependant je pense qu'il y a plus simple :
VB:
=SOMMEPROD((Calendrier!F7:AU31="CP")*(Calendrier!A7:A31=Donnee!A4))
Validation normale avec Entrée.
Bonjour Sylvanu,

Super cela marche très bien, et si jamais, vous auriez également une plus simple pour la cellule quis se trouve dans l'onglet "Donnee" J4, je vous repasse le fichier en pièce jointe

Merci beaucoup
 

Pièces jointes

  • tableau excel downldoad.xlsx
    164.2 KB · Affichages: 3

Discussions similaires

Statistiques des forums

Discussions
312 561
Messages
2 089 669
Membres
104 251
dernier inscrit
casino.macon