XL pour MAC Problème formule matricielle

Tenzor

XLDnaute Nouveau
Bonjour,
La formule matricielle qui fonctionnait jusqu'à aujourd'hui ne fonctionne plus et je n'en trouve pas la raison.
J'ai un fichier à priori assez simple avec l'année, les dates, des enseignes et des montants.
Je souhaite connaitre en K3 le chiffre total par enseigne, et en K5 le chiffre total par année, grâce aux formules matricielles, selon l'année en H1 et l'enseigne choisie en J1, sur les plages de A2:A10000 pour l'année, C2:C10000 pour les enseignes, et D2:D10000 pour les montants.
Le chiffre affiché est de 0 depuis aujourd'hui, sans explication...
Je valide bien mes formules par Ctrl, Maj et entrée...
Quelqu'un pourrait m'aider à résoudre ce problème SVP ?
Je suis sur Excel pour MAC 2019, ci joint le fichier en question.
D'avance un grand merci pour votre collaboration.
 

Pièces jointes

  • Enseignes.xlsm
    148.7 KB · Affichages: 4

mapomme

XLDnaute Barbatruc
Supporter XLD
Bonjour,

La formule en colonne A est : =SI(B2<>0;B2;"")
S'il y a une date en colonne B, alors A va contenir cette date sinon elle contiendra la chaine vide.

Une date n'est pas une année ! Vous confondez la valeur de la cellule (un nombre représentant un numéro de série de date) et ce que vous voyez (qui est défini par le format de la cellule).

Si en colonne B vous avez une date, alors dans la colonne A vous avez exactement la même valeur qu'en B (quelque soit le format choisi pour la cellule A). Si en B une date alors en A une date.

Pour avoir l'année, il faudrait la formule : =SI(B2<>0;ANNEE(B2);"")

edit : Bonjour @Phil69970 ;).
 
Dernière édition:

Phil69970

XLDnaute Barbatruc
Bonjour @Tenzor
Edit : Bonjour @mapomme

Plusieurs remarques

La formule matricielle qui fonctionnait jusqu'à aujourd'hui ne fonctionne plus et je n'en trouve pas la raison.
1) La raison est simple tu as modifié les formules de la colonne A
Solution :
Tu mets en A2 cette formule :
=SI(B2="";"";ANNEE(B2))
Et tu mets la colonne au format nombre

1680431440529.png

Et tirer ensuite la formule vers le bas

2) Tu peux te passer de la validation matricielle

Tu mets en K3 cette formule
=SOMMEPROD((A2:A10000=H1)*(C2:C10000=J1)*(D2:D10000))

Et en K5 cette formule
=SOMMEPROD((Plag_année=H1)*(Plag_montant))

Et miracle cela fonctionne


3) Mettre des noms dans le gestionnaire de noms avec des noms réservés par excel est une très mauvaise idée !!!! :mad:

1680431674836.png


Et avec un fichier cela donne ceci :

@Phil69970
 

Pièces jointes

  • Enseignes V1.xlsm
    145 KB · Affichages: 3

Discussions similaires

Réponses
11
Affichages
339
Réponses
4
Affichages
396
Réponses
10
Affichages
539

Statistiques des forums

Discussions
313 258
Messages
2 096 614
Membres
106 684
dernier inscrit
ekouepatrick