Autres problème de formule matricielle tri sans doublon avec un critère

Damilou

XLDnaute Nouveau
Bonjour

Voici mon problème j'ai une formule matricielle qui devrait faire le tri d'une liste sans doublon avec 2 critères
voici la formule
=SIERREUR(INDEX(B10:B281;PETITE.VALEUR(SI((D10:D281="ancien")*(CE10:CE281="o")*(EQUIV(B10:B281&D10:D281&CE10:CE281;B10:B281&D10:D281&CE10:CE281;0)=LIGNE(INDIRECT("1:"&LIGNES(CE10:CE281))));LIGNE(INDIRECT("1:"&LIGNES(CE10:CE281))));LIGNE(INDIRECT("1:"&LIGNES(CE10:CE281)))));"")

colonne B liste des noms comprenant des doublons , Colonne D le contenu doit être "ancien" et colonne CE le contenu doit être de "o"
en validant la formule par ctrl + maj+entrée j'obtiens voir ci dessous les doublons sont là , quelle erreur dans la formule matricielle pour enlever les doublons merci d'avance
Au Grand Sérieux
Au Grand Sérieux
Au Grand Sérieux
Gedis
Gedis
Les Berthoms Nancy
Les Berthoms Nancy
Les Berthoms Nancy
Les Berthoms Nancy
Les Berthoms Metz
Reddington Pub
Au grand Sérieux
Au grand Sérieux
Au grand Sérieux
Au grand Sérieux

 

job75

XLDnaute Barbatruc
Bonjour,

Npuvelle formule matricielle à tirer vers le bas :
Code:
=SIERREUR(INDEX(B$10:B$281;PETITE.VALEUR(SI((D$10:D$281="ancien")*(CE$10:CE$281="o")*(EQUIV(B$10:B$281&D$10:D$281&CE$10:CE$281;B$10:B$281&D$10:D$281&CE$10:CE$281;0)=LIGNE(INDIRECT("1:"&LIGNES(CE$10:CE$281))));LIGNE(INDIRECT("1:"&LIGNES(CE$10:CE$281))));LIGNE(A1)));"")
Les doublons sont bien éliminés.

A+
 

Damilou

XLDnaute Nouveau
Bonjour,

Npuvelle formule matricielle à tirer vers le bas :
Code:
=SIERREUR(INDEX(B$10:B$281;PETITE.VALEUR(SI((D$10:D$281="ancien")*(CE$10:CE$281="o")*(EQUIV(B$10:B$281&D$10:D$281&CE$10:CE$281;B$10:B$281&D$10:D$281&CE$10:CE$281;0)=LIGNE(INDIRECT("1:"&LIGNES(CE$10:CE$281))));LIGNE(INDIRECT("1:"&LIGNES(CE$10:CE$281))));LIGNE(A1)));"")
Les doublons sont bien éliminés.

A+
un grand merci JOB75
juste une explication sur la formule à la fin ligne(a1);"")
Code:
 pour ma culture
 

job75

XLDnaute Barbatruc
Bonjour Damilou,

Il suffit de retirer ce qui concerne la colonne D :
Code:
=SIERREUR(INDEX(B$10:B$281;PETITE.VALEUR(SI((CE$10:CE$281="o")*(EQUIV(B$10:B$281&CE$10:CE$281;B$10:B$281&CE$10:CE$281;0)=LIGNE(INDIRECT("1:"&LIGNES(CE$10:CE$281))));LIGNE(INDIRECT("1:"&LIGNES(CE$10:CE$281))));LIGNE(A1)));"")
A+
 

Discussions similaires

Statistiques des forums

Discussions
312 817
Messages
2 092 367
Membres
105 380
dernier inscrit
ASea DSea