XL 2010 Formule trop longue

saggigo

XLDnaute Occasionnel
Bonjour Le forum,
Je vous espère en bonne santé :)

Voilà je vous écris car j'ai un problème sur une formule. en effet elle est trop longue et j'aimerais savoir s'il y a un moyen de contourner ce problème sans passer par une macro.

j'ai mis en pièce jointe une feuille excel qui explique à peu pres le fonctionnement de la formule.

N'hésitez pas à me posez des questions
 

Pièces jointes

  • Book1.xlsx
    11.7 KB · Affichages: 44

JCGL

XLDnaute Barbatruc
Bonjour à tous,

En quoi la longueur de la formule te gène ?
Tu as une référence circulaire. Essaye avec :
Code:
=SI($M7="";$M$6;SI(ET($M7<>"";$O7="");$O$6;SI(ET($O7<>"";$Q7="");$Q$6;
SI(ET($Q7<>"";$T7="");$T$6;SI(ET($T7<>"";$W7="");$W$6;SI(ET($W7<>"";$Y7="");$Y$6;
SI(ET($Y7<>"";$AA7="");$AA$6;SI(ET($AA7<>"";$AE7="");$AE$6;SI(ET($AE7<>"";$AF7="");$AF$6;
SI(ET($AF7<>"";$AH7="");$AH$6;SI(ET($AH7<>"";$AK7="");$AK$6;SI(ET($AK7<>"";$AM7="");$AM$6;
SI(ET($AM7<>"";$AO7="");$AO$6;SI(ET($AO7<>"";$AP7="");$AP$6;SI(ET($AP7<>"";$AQ7="");$AQ$6;
SI(ET($AQ7<>"";$AU7="");$AU$6;""))))))))))))))))

A+ à tous
 

Discussions similaires

Réponses
17
Affichages
821

Statistiques des forums

Discussions
312 896
Messages
2 093 387
Membres
105 716
dernier inscrit
jrmdprt