Microsoft 365 Format heure

Ktrine

XLDnaute Nouveau
Bonjour à tous
J'ai un problème que je n'arrive pas à résoudre
Au quotidien, je travaille sur des balances horaires, positives ou négatives.
Il m'arrive de vouloir travailler sur ces cumuls d'heures
je télécharge donc l'ensemble d'1 service sur excel, les heures téléchargées ressortent sur ma feuille ainsi : 55h22 ou -22h30 par exemple et ce dans toute 1 colonne bien entendu..... Comment transformer mes 00h00 en 00:00 dans un premier temps et l'appliquer à l'ensemble de la colonne tout en gardant(difficulté supplémentaire....les + et les - car il y a des balances horaires négatives et postives. Je peux tout simplement faire un filtre dans un premier temps après avoir mis en évidence les + et les -mais lorsque je veux faire un TCD, je ne peux pas faire ce que je veux avec mes heures....
Pour l'instant j'ai une formule qui fonctionne pour 1 cellule ex -18h55 -la formule que j'utilise pour mettre au format 18:55 =TEXTE(185500;"00"":""00"":""00")*1. Ca fonctionne mais cela ne garde pas le signe -.:confused: Et ensuite je n'arrive pas à appliquer la formule a l'ensemble de la colonne, si je l'applique j'ai des 18:55 dans toutes les cellules....les autres horaires ne sont pas gardés en pj un exemple.
Peut-être que l'un d'entre connaîtrait une solution a mon problème, je ne me vois pas prendre mes X lignes et les formater manuellemento_O
Merci pour votre aide
 

Pièces jointes

  • test heures.xlsx
    9.2 KB · Affichages: 14

Modeste geedee

XLDnaute Barbatruc
Bonsour®
pour travailler avec des durées négatives 2 possibilités :
- travailler avec des durées décimales ( heures et centièmes)
- travailler avec l'option calendrier 1904 (comme les utilisiteurs MAC)
nb : souci lors des imports et échanges avec les utilisateurs PC les dates sont décalées de 1461 jours

ma proposition :
1032793


Nb:
probleme résiduel pour les durées positives > 24h ...
je cherche ....

;) euréka !!!
cette partie :
TEMPSVAL(SUBSTITUE(C2;"h";":"))
peut etre remplacée par :
1*SUPPRESPACE(SUBSTITUE(C2;"h";":"))
 
Dernière édition:

Ktrine

XLDnaute Nouveau
Bonsour®
pour travailler avec des durées négatives 2 possibilités :
- travailler avec des durées décimales ( heures et centièmes)
- travailler avec l'option calendrier 1904 (comme les utilisiteurs MAC)
nb : souci lors des imports et échanges avec les utilisateurs PC les dates sont décalées de 1461 jours

ma proposition :
Regarde la pièce jointe 1032793

Nb:
probleme résiduel pour les durées positives > 24h ...
je cherche ....
Merci infiniment pour cette réponse que je vais en pratique dès maintenant et vous tiens au courant ;)
 

Ktrine

XLDnaute Nouveau
Bonsour®
pour travailler avec des durées négatives 2 possibilités :
- travailler avec des durées décimales ( heures et centièmes)
- travailler avec l'option calendrier 1904 (comme les utilisiteurs MAC)
nb : souci lors des imports et échanges avec les utilisateurs PC les dates sont décalées de 1461 jours

ma proposition :
Regarde la pièce jointe 1032793

Nb:
probleme résiduel pour les durées positives > 24h ...
je cherche ....
Je tenterai cette méthode demain., mais j'aimerais aussi comprendre la formule, peux-tu me l'expliquer et qu'entends-tu par pb résiduel pour les durées positives? ça coince ou?
 

Jacky67

XLDnaute Barbatruc
Super cette méthode fonctionne bien, faut juste faire les 2 colonnes
Par contre peux-tu, m'expliquer les 2 formules car j'aime bien comprendre et éventuellement pouvoir expliquer si on me le demande :)
Encore merci
RE...
1-Colonne E
=SI(GAUCHE(C3;2)<>" -";SUBSTITUE(SUBSTITUE(C3;"h";":");" ";"")*1;"")
Cette formule ne prend en compte que est les heures positives ==> Si(GAUCHE(C3;2)<>" -"---------);sinon "")
-Que les cellules qui commencent pas par " -" ==> GAUCHE(C3;2)<>" -"
-Elle remplace les "h" par un ":" ==> SUBSTITUE(C3;"h";":") pour utiliser un format reconnu par Excel
-Elle supprime les " " (espace) ==> SUBSTITUE(SUBSTITUE(C3;"h";":");" ";"")
-Elle multiplie le tout par 1 pour être numérique et calculable.
2-Colonne F
=SI(GAUCHE(C3;2)=" -";SUBSTITUE(SUBSTITUE(C3;"h";":");" -";"")*1;"")

Cette formule ne prend en compte que est les heures négatives==> Si(GAUCHE(C3;2)=" -"---------);sinon "")
-Que les cellules qui commencent par " -" ==> GAUCHE(C3;2)=" -"
-Elle remplace les "h" par un ":" ==> SUBSTITUE(C3;"h";":") pour utiliser un format reconnu par Excel
-Elle supprime les " -" ==> SUBSTITUE(SUBSTITUE(C3;"h";":");" -";"") pour ne être obligé de passer en mode "calendrier 1904"
-Elle multiplie le tout par 1 pour être numérique et calculable.

Bon courage.
 
Dernière édition:

Modeste geedee

XLDnaute Barbatruc
Je tenterai cette méthode demain., mais j'aimerais aussi comprendre la formule, peux-tu me l'expliquer et qu'entends-tu par pb résiduel pour les durées positives? ça coince ou?

si la fonction TROUVE "-" est en erreur alors c'est un temps positif
. on substitue "h" par ":" et on applique la fonction TEMPSVAL au texte reconstitué
si la fonction TROUVE n'est pas en erreur alors c'est un temps négatif
. on substitue "h" par ":" on ne prend le texte reconstitué qu'après le signe "-"
. excel reconnait alors une représentation horaire
. on multiplie le tout par -1

la cellule doit être au format : [hh]:mm

:(l'utilisation de la fonction TEMPVAL est limitée à 24h...
cette partie :
TEMPSVAL(SUBSTITUE(C2;"h";":"))
peut etre remplacée par :
1*SUPPRESPACE(SUBSTITUE(C2;"h";":"))
 

Ktrine

XLDnaute Nouveau
RE...
1-Colonne E
=SI(GAUCHE(C3;2)<>" -";SUBSTITUE(SUBSTITUE(C3;"h";":");" ";"")*1;"")
Cette formule ne prend en compte que est les heures positives ==> Si(GAUCHE(C3;2)<>" -"---------);sinon "")
-Que les cellules qui commencent pas par " -" ==> GAUCHE(C3;2)<>" -"
-Elle remplace les "h" par un ":" ==> SUBSTITUE(C3;"h";":") pour utiliser un format reconnu par Excel
-Elle supprime les " " (espace) ==> SUBSTITUE(SUBSTITUE(C3;"h";":");" ";"")
-Elle multiplie le tout par 1 pour être numérique et calculable.
2-Colonne F
=SI(GAUCHE(C3;2)=" -";SUBSTITUE(SUBSTITUE(C3;"h";":");" -";"")*1;"")

Cette formule ne prend en compte que est les heures négatives==> Si(GAUCHE(C3;2)=" -"---------);sinon "")
-Que les cellules qui commencent par " -" ==> GAUCHE(C3;2)=" -"
-Elle remplace les "h" par un ":" ==> SUBSTITUE(C3;"h";":") pour utiliser un format reconnu par Excel
-Elle supprime les " -" ==> SUBSTITUE(SUBSTITUE(C3;"h";":");" -";"") pour ne être obligé de passer en mode "calendrier 1904"
-Elle multiplie le tout par 1 pour être numérique et calculable.

Bon courage.
Merci. Génial. Y a plus qu'à.
 

Discussions similaires

Statistiques des forums

Discussions
312 922
Messages
2 093 644
Membres
105 775
dernier inscrit
assen