XL 2019 soustraction heure au format texte

boguinette

XLDnaute Nouveau
Bonjour à tous,
J'ai une petite question qui je pense va sembler "bête" à certains, mais je ne trouve pas d'astuce... J'ai une base de données avec plein d'heures d'entrées et d'heures de sorties, mais les cellules sont au format texte. Je voudrais faire une soustraction entre les 2 heures pour avoir mon délai d'attente et analyser les données, sauf qu'une simple soustraction ne fonctionne pas vu que je suis en format texte... J'ai essayé =TEXTE(B3;"hh:mm:mm), mais ça ne fonctionne pas... J'ai essayé =Gauche..... Pareil... j'ai toujours VALEUR qui s'affiche dans ma cellule ou je veux avoir mon délai d'attente...
Je voudrais éviter d'avoir à recopier 200 lignes d'heures ligne par ligne, si c'est possible bien sur... :)
Est ce que quelqu'un peut m'aider la dessus ? Je met un fichier en pièce jointe pour expliquer mon petit soucis !
Belle fin de journée !!
 

Pièces jointes

  • test-1.xlsx
    10 KB · Affichages: 5

Cousinhub

XLDnaute Barbatruc
Bonjour,
Il suffit de sélectionner les données, puis Ctrl + H (Ou Edition/Remplacer)
Mettre le point ( . ) comme valeur à remplacer
Et le 2 points ( : ) comme nouvelle valeur
Les données se transforment alors en format horaire, et la soustraction fonctionne
Bonne apm
 

Statistiques des forums

Discussions
313 258
Messages
2 096 614
Membres
106 685
dernier inscrit
phob