Microsoft 365 Différence d'heures entre deux dates avec deux plages horaires + jours fériés

ksebf

XLDnaute Nouveau
Bonjour à tous,

J'espère que tout le monde se porte bien en ce début d'année 2022 !

Je cherche à créer une cellule me calculant la différence entre deux dates en heures. J'ai parcouru le forum et j'ai trouvé une formule qui ma va bien, mais il me manque la façon de rajouter deux plages horaires dans la journée et en prenant en compte les jours fériés.

Actuellement, avec cette formule, j'ai les heures entre deux dates en prenant en compte les jours ouvrés, une heure de début et une heure de fin.

=SI(ET(D2<>"";E2<>"");(NB.JOURS.OUVRES(D2;E2)-1)*(L$2-I$2)+SI(NB.JOURS.OUVRES(E2;E2);MEDIANE(MOD(E2;1);L$2;I$2);L$2)-MEDIANE(NB.JOURS.OUVRES(D2;D2)*MOD(D2;1);L$2;I$2);0)

Ce que j'aimerais rentrer dans cette formule, c'est une prise en compte des heures seulement entre :
8:00 et 12:00 (I2;J2)
14:00 et 18:00 (K2;L2)

Le but pour moi est que si la date de début commence à 11:30 et la date de fin est à 14:30, j'obtienne un résultat d'une heure (et pas trois comme c'est déjà le cas !)

et les jours fériés (N2:N7)
18/04/2022
26/05/2022
06/06/2022
14/07/2022
15/08/2022
01/11/2022

Si vous avez une idée, je suis preneur :)
 

Pièces jointes

  • Différence heure entre dates test.xlsx
    14.3 KB · Affichages: 22
Solution
Re, ta formule fonctionne Djidji avec une erreur d'heure dans la journée il me semble. J'ai remplacé le 6/24 par un 8/24 pour avoir la bonne valeur sur l'ensemble :)

Du coup j'ai fonctionné aussi sur une période avec un jour férié, et tout fonctionne correctement !

=SI(ET(MOD(D7;1)<M;MOD(E7;1)>ApM);(NB.JOURS.OUVRES.INTL(D7;E7;1;fériés)-1)*8/24+MOD(E7-D7;1)-repas;SI(ET(MOD(D7;1)<M;MOD(E7;1)<M);(NB.JOURS.OUVRES.INTL(D7;E7;1;fériés)-1)*8/24+MOD(E7-D7;1)-SI(JOUR(D7)=JOUR(E7-1);0;repas);SI(ET(MOD(D7;1)>ApM;MOD(E7;1)>ApM);(NB.JOURS.OUVRES.INTL(D7;E7;1;fériés)-1)*8/24+MOD(E7-D7;1))))

jyutyn

XLDnaute Nouveau
Re, ta formule fonctionne Djidji avec une erreur d'heure dans la journée il me semble. J'ai remplacé le 6/24 par un 8/24 pour avoir la bonne valeur sur l'ensemble :)

Du coup j'ai fonctionné aussi sur une période avec un jour férié, et tout fonctionne correctement !

=SI(ET(MOD(D7;1)<M;MOD(E7;1)>ApM);(NB.JOURS.OUVRES.INTL(D7;E7;1;fériés)-1)*8/24+MOD(E7-D7;1)-repas;SI(ET(MOD(D7;1)<M;MOD(E7;1)<M);(NB.JOURS.OUVRES.INTL(D7;E7;1;fériés)-1)*8/24+MOD(E7-D7;1)-SI(JOUR(D7)=JOUR(E7-1);0;repas);SI(ET(MOD(D7;1)>ApM;MOD(E7;1)>ApM);(NB.JOURS.OUVRES.INTL(D7;E7;1;fériés)-1)*8/24+MOD(E7-D7;1))))
Bonjour
J'ai utilisé la formule mais le problème que je rencontre cest que quand l'heure de début et de fin sont avant 12h30 elle marche pas .
Merci
 

Pièces jointes

  • calcul heure de production test.xlsx
    29 KB · Affichages: 1

Discussions similaires

Statistiques des forums

Discussions
300 762
Messages
1 987 022
Membres
209 682
dernier inscrit
tecloveur