XL 2019 Faire un sommeprod ou somme.si.ens pour réaliser un cumul

Merlin258413

XLDnaute Occasionnel
Bonjour
je viens solliciter votre aide pour savoir s'il est possible de faire un cumul avec les fonctions sommeprod ou somme.si.ens
Mon critère se trouve en P9 et mon résultat en P11.
En fonction de mon mois saisi j'effectue la somme des mois jusqu'à ce dernier
par exemple si j'ai le mois de mars j'effectue la somme de janvier à mars ...

La fonction actuelle que le forum m'a donné fonctionne parfaitement.
En vous remerciant par avance pour votre aide
Cordialement
 

Pièces jointes

  • Copie de Classeur1 (1).xlsx
    16 KB · Affichages: 8

Hasco

XLDnaute Barbatruc
Repose en paix
Re,

Je vous ai donné une 'sommepod' sur votre autre fil sur le sujet. Pourquoi recréer une discussion ?
cordialement
 

Hasco

XLDnaute Barbatruc
Repose en paix
Cela pouvait se faire dans le même fil de discussion. Vous auriez simplement du le notifier.


Avec des dates sur la ligne 10
=SOMMEPROD((B11:M11)*(B10:M10<=P9))
Avec somme.si
=SOMME.SI($B$10:$M$10;"<=" & FIN.MOIS(P9;0);$B$11:$M$11)

Réservez Sommeprod que pour les cas où d'autres solutions n'existent pas.

Cordialement
 

Merlin258413

XLDnaute Occasionnel
Cela pouvait se faire dans le même fil de discussion. Vous auriez simplement du le notifier.


Avec des dates sur la ligne 10
=SOMMEPROD((B11:M11)*(B10:M10<=P9))
Avec somme.si
=SOMME.SI($B$10:$M$10;"<=" & FIN.MOIS(P9;0);$B$11:$M$11)

Réservez Sommeprod que pour les cas où d'autres solutions n'existent pas.

Cordialement
JE vous remercie infiniment c'est exactement ce que je recherchais
 

Discussions similaires

Réponses
3
Affichages
654
Membre supprimé 341069
M

Statistiques des forums

Discussions
312 932
Messages
2 093 730
Membres
105 802
dernier inscrit
Witchun