XL 2021 Calcule consommation de carburant

ayoub456

XLDnaute Nouveau
Bonjour,

Je me rends ici afin de solliciter votre aide.

À l'heure actuelle, je dispose d'une flotte de 10 véhicules circulant au Gasoil.

Je dispose également d'un outil d'analyse. Il repose sur les données que nous collectons chaque mois de la station.

J'ai à ma disposition par la station de carburant les valeurs / données suivantes :

  • Date du plein
  • Kilométrage du véhicule
  • La quantité de carburant achetée (en litres)
  • Le nom du véhicule (code interne)
À partir des informations ci-dessus, nous déterminons :

  • Les kilomètres effectués entre deux pleins
  • La consommation aux 100 kilomètres
  • Le prix du litre de carburant
Je souhaiterai élaborer un seul tableau de saisie pour gagner en efficacité. Et n'avoir, en conséquence qu'un seul onglet d'analyse avec une liste déroulante des véhicules de mon parc.

J'ai d'abord pensé à un tableau croisé dynamique, mais je vois mal comment calculer la consommation de carburant, qui consiste à faire l'opération suivante :

[(quantité de carburant achetée)/(kilométrage parcouru)]x100

Autant une Pivot Table, permet de lire les données, mais permet difficilement de faire des calculs de ce type.

Il faut que ce champ soit dynamique et prenne aussi bien en compte le véhicule que la suite logique sur les dates. Puisque la consommation se calcule entre les deux dates les plus proches pour un véhicule donné.

Je me suis demandé s'il ne fallait pas inclure un champ calculé directement dans la base de donnée, mais les données étant saisies au fil de l'eau, je vois mal comment rappeler la valeur du précédent plein et qui forcément n'est pas la ligne précédente.

Je connais la fonction VLOOKUP, mais qui ne ramène ici que la première valeur d'une série. La clef commune étant le nom du véhicule. Il semblerait qu'agrémenter cette fonction d'INDEX et MATCH, puisse aider, mais je vois mal comment l'appliquer dans ce cas de figure.

Certains ici visualiseront probablement mieux que moi la meilleure des méthodes, étant encore un peu débutant sur ce type d'opérations.

Vous remerciant d'avance,
 

Pièces jointes

  • transport.xlsx
    19.4 KB · Affichages: 40
Dernière édition:

JHA

XLDnaute Barbatruc
Bonjour à tous,

A essayer
VB:
=SI(GRANDE.VALEUR(SI(($A$6:$A6=$A6)*($B$6:$B6<$B6);$F$6:$F6;0);1)=0;0;$F6-GRANDE.VALEUR(SI(($A$6:$A6=$A6)*($B$6:$B6<$B6);$F$6:$F6;0);1))

JHA
 

Pièces jointes

  • transport.xlsx
    19.6 KB · Affichages: 15

Discussions similaires

Statistiques des forums

Discussions
313 283
Messages
2 096 811
Membres
106 751
dernier inscrit
Souleymani