Microsoft 365 Excel : regrouper des doublons sur plusieurs lignes

Chloé Asso

XLDnaute Nouveau
Bonjour,
je travaille dans une association et nous aidons d'autres assos dans leur gestion.
Je sèche sur une demande excel ou un outil de CRM a exporté des données de manière pas top.

J'ai des binômes de personnes avec une date de début de binome et une date de fin de binome, le problème c'est que ça me les a mis sur deux lignes

Exemple :
X / Y / 01/01/2023 /
X / Y / / 15/06/2023

Je voudrais obtenir :

X / Y / 01/01/2023 / 15/06/2023

Puis ajouter dans une dernière colonne la durée calculée du binome.

Certain binome n'ont pas de date de fin car court toujours et dans ce cas j'aimerais que ca me mettre automatiquement le 31/12/2023.

J'ai mis un modèle ci-joint.

Le fichier fait plus de 4000 ligne donc une action manuelle est exclue.

Merci infiniment pour votre aide.
 

Pièces jointes

  • Binome affiliation.xlsx
    9.5 KB · Affichages: 5

chris

XLDnaute Barbatruc
Bonjour

Le plus simple est d'utiliser PowerQuery intégré à Excel.

J'imagine que l'export est un csv.

Si oui, peux-tu ouvrir avec notepad et surtout pas Excel pour anonymiser 10 lignes et supprimer les autres et joindre le csv (en le zippant au besoin)
 

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Cloé, et bienvenue sur XLD,
Si la structure des données est bien toujours la même, alors en PJ un essai avec :
VB:
Parrain      :  =INDEX(A:A;2*LIGNE()-3)
Filleul      :  =INDEX(B:B;2*LIGNE()-3)
Affilié      :  =INDEX(C:C;2*LIGNE()-3)
Désafillié   :  =INDEX(D:D;2*LIGNE()-2)
Durée binôme :  =SI(I3=0;0;SI(J3=0;DATE(2023;12;31)-I3;J3-I3))
L'option "Afficher un zéro ... " est décochée.
 

Pièces jointes

  • Binome affiliation.xlsx
    11.8 KB · Affichages: 3

Cousinhub

XLDnaute Barbatruc
Bonjour,
Une solution Power Query (j'ai rajouté quelques lignes, pour, j'espère, couvrir l'ensemble des possibilités)
On peut aussi, si ça t'intéresse, rajouter des calculs s'il y a des dates de l'année en cours..
Bon appétit
 

Pièces jointes

  • PQ_Binome affiliation.xlsx
    18.6 KB · Affichages: 6

Chloé Asso

XLDnaute Nouveau
Bonjour et merci à tous les deux pour votre aide !


Bonjour Cloé, et bienvenue sur XLD,
Si la structure des données est bien toujours la même, alors en PJ un essai avec :
VB:
Parrain      :  =INDEX(A:A;2*LIGNE()-3)
Filleul      :  =INDEX(B:B;2*LIGNE()-3)
Affilié      :  =INDEX(C:C;2*LIGNE()-3)
Désafillié   :  =INDEX(D:D;2*LIGNE()-2)
Durée binôme :  =SI(I3=0;0;SI(J3=0;DATE(2023;12;31)-I3;J3-I3))
L'option "Afficher un zéro ... " est décochée.

Sylvanu : non la structure n'est pas toujours la meme car parfois un binome a 2 lignes (date de début et date de fin ) et parfois une seule ligne quand pas de date de fin, seulement une date de début. J'ai testé et ca ne fonctionne plus dès qu'un binome n'a qu'une ligne.


Bonjour

Le plus simple est d'utiliser PowerQuery intégré à Excel.

J'imagine que l'export est un csv.

Si oui, peux-tu ouvrir avec notepad et surtout pas Excel pour anonymiser 10 lignes et supprimer les autres et joindre le csv (en le zippant au besoin)

Chris, mon fichier est bien en excel car on a déjà "nettoyé" pour enlever les vides, les dates antérieures à 2023, les champs sans intérêt...
 

Chloé Asso

XLDnaute Nouveau
bonsoir, oui mais comme je n'y connais rien en power query...
JHA et Cousinhub m'ont fait un modèle et j'ai réussi à faire ce que je souhaitais.

Merci infiniment pour votre aide précieuse !
Bravo pour ce forum :) et bonne soirée

Chloé
 
Dernière édition:

Discussions similaires

Réponses
2
Affichages
550

Statistiques des forums

Discussions
312 534
Messages
2 089 386
Membres
104 153
dernier inscrit
Pascalmorin