XL 2016 Trouver des valeurs sur des dates N-1

alain.raphael

XLDnaute Occasionnel
Bonjour à Tous,

J'ai 2 petites formules qui requêtent sur les 7 derniers JOURS et sur le dernier MOIS (à partir de la date du jour), soit :

=NB.SI.ENS('Export FV'!F$2:F$2000;">=" & AUJOURDHUI()-7;'Export FV'!Q$2:Q$2000;1)

=NB.SI.ENS('Export FV'!F$2:F$2000;">=" & MOIS.DECALER(AUJOURDHUI();-1);'Export FV'!Q$2:Q$2000;1)

Je souhaiterai requêter sur les mêmes périodes .... mais de l'année dernière...(exemple pour la 1ère formule du 08 mai au 15 mai 2023).

Ma base de donnée possède une colonne (F) avec des dates comme suit : 07/03/2024 19:46:01

Merci !
 
Dernière édition:

alain.raphael

XLDnaute Occasionnel
Merci Chris....mais est-ce que ces formules ne vont pas calculer le nombre depuis 1an et 7 jours...... et depuis 13 mois.

Il me faut juste les 7 derniers jours à partir d'aujourd'hui (mais de 2023), soit 08 au 15 mai 2023 si aujourd'hui....... et du 15 avril au 15 mai 2023 si aujourd'hui...
 

alain.raphael

XLDnaute Occasionnel
Non pour l'instant il ne calcule pas :

BARRE.png


Peu importe les signes d'ailleurs ><
 

TooFatBoy

XLDnaute Barbatruc
Tel que tu l'as écrit ça ne peut pas fonctionner : tu ne peux pas faire A(<=B ET >=C).
Il faut faire A<=B ET A>=C.
Et comme je disais précédemment, si ça ne marche pas avec nb.si.ens alors essaye avec sommeprod.


Tant qu'on n'aura pas quelque chose de concret à se mettre sous la dent, on risque de tâtonner longtemps. :(
 
Dernière édition:

TooFatBoy

XLDnaute Barbatruc
Avec le Sommeprod je trouve 41. Est-ce le résultat attendu ?
Avec nb.si.ens aussi je trouve 41. ;)

Une fois qu'on a tout remis dans le bon ordre, ça marche ;) :
Code:
=NB.SI.ENS('Export 2023'!F$2:F$2000; ">=" & MOIS.DECALER(AUJOURDHUI(); -13); 'Export 2023'!F$2:F$2000; "<=" & MOIS.DECALER(AUJOURDHUI(); -12); 'Export 2023'!Q$2:Q$2000; 7)
 

Discussions similaires

Réponses
2
Affichages
590

Membres actuellement en ligne

Aucun membre en ligne actuellement.

Statistiques des forums

Discussions
313 271
Messages
2 096 724
Membres
106 720
dernier inscrit
Alain EDZOA