Microsoft 365 [EXCEL] Comptage du nombre de clients uniques pour un article.

Julien75002

XLDnaute Nouveau
Bonjour,
Depuis 3 jours je suis en boucle sur un problème de comptage..... ;(

J'ai deux tables :
- Articles
- Ventes

Dans ma première table, j'ai la liste des mes Articles. (Code article / Désignation / Nb de ventes / Nb Clients uniques)
Capture d’écran 2023-04-10 à 11.55.41.png



Dans la seconde table, j'ai la liste des mes Ventes. (Vente N° / Code article / Quantité / Code client)

Capture d’écran 2023-04-10 à 11.55.53.png



Je souhaite, dans ma première table Article compter le nombre clients uniques que j'ai pour un article, c'est à dire, si j'ai fait plusieurs ventes à un même clients, le compter une seule fois.

Ici par exemple le nombre de mes clients uniques pour mon Article 1 - Pomme est de 4.

Auriez-vous une solution, une piste ..... 😀

Par avance merci de votre aide.
Bon week-end de Pâques 🐣 à vous tous.

Julien
 

Pièces jointes

  • TEST_COMPTAGE_CLIENTS_UNIQUES.xlsx
    12.5 KB · Affichages: 6

JHA

XLDnaute Barbatruc
Bonjour à tous,

Pour ceux qui n'ont pas Office 365, comme moi 😭, une proposition similaire à @djidji59430 que je salue :)

VB:
=SOMME(SI(FREQUENCE(SI(VENTES[Qté]=$B3;EQUIV(VENTES[CLIENT];VENTES[CLIENT];0));LIGNE(VENTES[CLIENT])-LIGNE($A$19));1))

JHA
 

Pièces jointes

  • TEST_COMPTAGE_CLIENTS_UNIQUES.xlsx
    14.5 KB · Affichages: 3

Discussions similaires

Statistiques des forums

Discussions
313 193
Messages
2 096 081
Membres
106 491
dernier inscrit
schneider