XL 2016 effacer le contenu d'une cellule contenant un menu deroulant

hdparcs

XLDnaute Junior
Bonjour à tous,
En A1, j'affiche un texte au moyen d'un menu déroulant.
En A2, j'ai également un menu déroulant mais je souhaiterais que le texte affiché s'efface automatiquement chaque fois que je modifie A1 pour refaire le choix que je désire en A2.
Je pensais insérer une formule dans la Source de la Liste de Validation de données avec une formule du genre =SI(A1 modifié;RECHERCHEV(A1;Feuil!A1:B10;2);Liste déroulante) en laissant la colonne B de Feuil! vide ou à 0.
Cela peut-il fonctionner et quelle serait la formule.
J'ai lu qu'il existe une possibilité avec le VBA mais, à part accéder au code en cliquant droit sur l'onglet, je suis incapable de comprendre quelque chose à ce système et langage.
Je remercie d'avance celui qui pourra m’apporter la bonne formule, si elle existe.
Bonne journée
 
Solution
Bonjour,
A tester en VBA à mettre ce code dans la feuille même avec raccourci Alt + F11

VB:
Private Sub worksheet_selectionchange(ByVal target As Range)
If Not Intersect(target, Range("A1")) Is Nothing Then
Range("A1").Value = ""
Range("A2").Value = ""
End If
If Not Intersect(target, Range("A1", "A2")) Is Nothing Then
End If
End Sub

Slts

riton00

XLDnaute Impliqué
Bonjour,
A tester en VBA à mettre ce code dans la feuille même avec raccourci Alt + F11

VB:
Private Sub worksheet_selectionchange(ByVal target As Range)
If Not Intersect(target, Range("A1")) Is Nothing Then
Range("A1").Value = ""
Range("A2").Value = ""
End If
If Not Intersect(target, Range("A1", "A2")) Is Nothing Then
End If
End Sub

Slts
 

Discussions similaires

Statistiques des forums

Discussions
313 195
Messages
2 096 101
Membres
106 495
dernier inscrit
dylan.44