XL pour MAC Créer un calendrier avec changement de date automatique toutes les 30 lignes

Gubake

XLDnaute Nouveau
Bonjour à tous,

Je sollicite votre aide aujourd'hui car je crée un planning dans lequel je cherche à changer de date toutes les 30 lignes.

Auriez-vous une solution pour réaliser cette fonction sans macro ou via ?
Sachant que je ne veux pas faire apparaître les weekends et jours fériés car les équipes travaillent 365 jours / an.

Merci d'avance.

Bonne journée.

Cédric
 

Deadpool_CC

XLDnaute Impliqué
Bonjour
quelle forme ton calendrier ?
toutes les date en 1 seule colonne ?
OU matrice avec une semaine par ligne
Ou matrice avec un mois par ligne ?

si colonne, alors A1=01/01/2022
en A2 = A1+1 et ensuite tu tires ta formule en A2 aussi bas que de besoin
 

Deadpool_CC

XLDnaute Impliqué
Bonjour,

Essaye avec :
* A2 contient ta date de départ
* A3 avec la formule ci-dessous que tu tire ensuite vers le bas.
VB:
=SI(MOD(NB.SI(A$2:A2;A2);30)<>0;A2;MAX(A$2:A2)+1)
avec cela même l'insertion d'un ligne vide devrait pas casser la logique.
dis moi si c'est ok
 

Pièces jointes

  • Classeur2.xlsx
    18.1 KB · Affichages: 3

Hasco

XLDnaute Barbatruc
Bonjour,
je souhaite que les cellules A2:A32 soient à la date du 1er janvier. Les cellules A33;A63 à la date du 2 janvier.
1 - ça fait 31 lignes pas 30
2 - Le 1 janvier étant toujours férié c'est incohérent avec :
Sachant que je ne veux pas faire apparaître les weekends et jours fériés car les équipes travaillent 365 jours / an.

Avec week-end et jours fériés :
=DATE(2022;1;1)+ENT((LIGNE()-2)/30)
Sans week-end et jours fériés:

=SERIE.JOUR.OUVRE(DATE(2021;12;31);1+ENT((LIGNE()-2)/30);Fériés)

Fériés étant une plage de cellules contenant les dates de jours fériés.

Fériés 2022 :
01/01/2022
18/04/2022
01/05/2022
08/05/2022
26/05/2022
06/06/2022
14/07/2022
15/08/2022
01/11/2022
11/11/2022
25/12/2022

Si vous copier/coller ces dates fériés, attention à ce qu'elles ne soit pas collées en texte mais en numérique.

Ce qui nous fait pour 2022 une colonne de 7590 lignes sans week-end ni jour férié et 10901 avec


Cordialement
 
Dernière édition:

Discussions similaires

Statistiques des forums

Discussions
299 845
Messages
1 979 507
Membres
206 754
dernier inscrit
Jacqueline ANDRAULT