Creation Tableau De Calcul De Location

LILOUM44

XLDnaute Nouveau
Bonjour à toutes et tous,

Je viens vers vous car je viens de me créer un petit tableau afin de calculer un montant de location en fonction d'une période de location.
Le souci que je rencontre c'est que la location peut avoir lieu sur plusieurs années mais le prix de location évolue selon les années.
J'ai réussi a faire quelque chose sur la feuille 2 du document mais cela ne me convient pas trop concernant la saisie de la période.......
Je souhaiterai sur la feuille 1 une formule de calcule qui me calculerait le montant de location en prenant en compte les éléments suivants :
- la période de location sur plusieurs années;
- la variation des prix moyen journalier en fonction des années.
Je vous fais suivre mon tableau et reste à votre disposition pour de plus amples renseignements si je n'étais pas assez clair.
Merci d'avance pour votre aide.
 

Pièces jointes

  • DOC DATE + LOCATIONS.xls
    18.5 KB · Affichages: 390
  • DOC DATE + LOCATIONS.xls
    18.5 KB · Affichages: 405
  • DOC DATE + LOCATIONS.xls
    18.5 KB · Affichages: 389

LILOUM44

XLDnaute Nouveau
Re : Creation Tableau De Calcul De Location

Bonjour Larson et autres,

Je reviens vers vous car je viens de constater "une coquille" sur une des formules que du tableau de larson. En effet, il y a une erreur sur le montant que le tableau communique lorsque la periode saisie est inferieur à un an par exemple du 01/04/08 au 01/05/08 le montant communiqué par le tableau est de 169.13 euros alors qu'en réalité il est de 13.24 euros.

Il y a un problème sur les formules sur les champs F20 et F21.

Merci de me filer un petit coup de main les amis.

Bien cordialement.

LILOUM44
 

Tibo

XLDnaute Barbatruc
Re : Creation Tableau De Calcul De Location

Bonjour,

Une idée qui doit pouvoir être simplifiée :

Code:
=SOMMEPROD((ANNEE(B7+LIGNE(INDIRECT("1:"&E7-B7))-1)=D11)*F11)+
SOMMEPROD((ANNEE(B7+LIGNE(INDIRECT("1:"&E7-B7))-1)=D12)*F12)+
SOMMEPROD((ANNEE(B7+LIGNE(INDIRECT("1:"&E7-B7))-1)=D13)*F13)+
SOMMEPROD((ANNEE(B7+LIGNE(INDIRECT("1:"&E7-B7))-1)=D14)*F14)+
SOMMEPROD((ANNEE(B7+LIGNE(INDIRECT("1:"&E7-B7))-1)=D15)*F15)

Calcul basé sur le prix de journée

@+
 

Discussions similaires

Statistiques des forums

Discussions
312 913
Messages
2 093 535
Membres
105 752
dernier inscrit
fred13340