XL 2016 Consommation journalière avec graphique

amgue

XLDnaute Junior
Bonjour à tous,

J’aimerais calculer la somme de dépenses par date.

Feuille du mois en cours : "décembre"

Les jours en chiffres sont inscrits dans la ligne 50 en partant de la cellule K50 jusqu’à AO50.

Le mois en cours en $F$2 (=décembre)

La sommes des débits dans la colonne : Tableau2[Débit]

Test du jour du mois : TEXTE(Tableau2[Date de l''opération];"j")=Décembre!K50

Test du nom du mois : TEXTE(Tableau2[Date de l''opération];"mmmm")=Décembre!$F$2

Formule en K51 :
VB:
=SOMMEPROD(Tableau2[Débit]*(TEXTE(Tableau2[Date de l''opération];"j")=Décembre!K50)*(TEXTE(Tableau2[Date de l''opération];"mmmm")=Décembre!$F$2))

Mais j’obtiens toujours la même valeur 0 pour toutes les journées du mois !

Une solution ?

Merci d’avance.
 
Solution
Bonjour,
Pour la ligne 19, je dois expliquer que les jours du 26 du mois en cours au 26 du mois suivant doivent être inclus, car le mois budgétaire commence le 26 de chaque mois.
Ca, c'était difficile à imaginer. :)
D'autre part, un mois budgétaire va du 26 au 25, et non du 26 au 26 car sinon le 26 serait compté deux fois, sur le mois précédent et sur le mois suivant. ( sinon modifier les formules en conséquence )
En PJ pas mal de modifs :
Début du calendrier en B19 :
VB:
=MOIS.DECALER(CNUM("26 "&F2&" "&An);-1)
Puis de C19 à AA19 : = B19+1
A partir de AB19 on peut avoir plusieurs configurations suivant les mois pour ne pas dépasser le 25 :
Code:
=SIERREUR(SI(JOUR(AA19+1)>25;"";AA19+1);"")
Puis pour débit et crédit ...

Discussions similaires

Statistiques des forums

Discussions
313 265
Messages
2 096 667
Membres
106 704
dernier inscrit
Mymy.ol