XL 2010 compter des plages si 2 conditions remplies

ymanot

XLDnaute Occasionnel
Bonjour à tous,
je bute sur une recherche
je souhaite compter dans mes classes le nombre de fois qu'apparaissent des scores
Vous trouverez en pj 2 images (car mon classeur est full macro ce qui fait peur en general)

image 1 : capture d'un listing avec la colonne A dans laquelle rechercher par exemple :
compter si colonne A contient 01 et colonne F = 1
compter si colonne A contient 01 et colonne F = 1.5
compter si colonne A contient 01 et colonne F = 2
compter si colonne A contient 01 et colonne F = 2.5
compter si colonne A contient 01 et colonne F = 3
compter si colonne A contient 01 et colonne F = 3.5
compter si colonne A contient 01 et colonne F = 4
image 2 le récapitulatif dans lequel je veux faire entrer les données.
Ensuite avec la formule pour 01 je ferai la même chose pour les classes 01,02,03,04,05,06,07,...
je pense à la formule NB.SI.ENS mais je ne sais pas comment la tourner

quelqu'un peut il m 'aider svp
Thierry
 

Pièces jointes

  • Capture d’écran 2022-07-03 183905.png
    Capture d’écran 2022-07-03 183905.png
    57.4 KB · Affichages: 12
  • Capture d’écran 2022-07-03 183458.png
    Capture d’écran 2022-07-03 183458.png
    24.6 KB · Affichages: 9

ymanot

XLDnaute Occasionnel
Bonjour,
La premiere formule fonctionnait, pour améliorer la recopie j'ai tenté la 2ème mais j'ai du faire une erreur
pour la colonne X13
=SOMMEPROD((TRI!$A$4:$A$166=$X$13)*(TRI!$F$4:$F$166=Q14))
il y a une erreur que je ne comprends pas
 

Wayki

XLDnaute Impliqué
Bonjour,
La premiere formule fonctionnait, pour améliorer la recopie j'ai tenté la 2ème mais j'ai du faire une erreur
pour la colonne X13
=SOMMEPROD((TRI!$A$4:$A$166=$X$13)*(TRI!$F$4:$F$166=Q14))
il y a une erreur que je ne comprends pas
Je sais pas ça devrait fonctionner, essayez X$13 et $Q14.
Comme ça vous figez respectivement les classes dans la colonne A et les notes dans la colonne F.
Sinon il faut le fichier ou au moins une capture.
A +
 

Discussions similaires

Réponses
6
Affichages
448

Membres actuellement en ligne

Aucun membre en ligne actuellement.

Statistiques des forums

Discussions
299 832
Messages
1 979 414
Membres
206 721
dernier inscrit
Sud catering