XL 2019 Compter avec Sommeprod

Rabeto

XLDnaute Occasionnel
Bonjour,

J'essaie de faire un comptage de valeur par sommeprod en fonction de quelques critères,
Compter en global j'arrive à le faire en utilisant : =SOMMEPROD(--(MOIS($B2:$B200)=MOIS(1&F1))*($B2:$B200<>""))

Mais quad j'ajoute d'autre critère, comme par exemple si la liste contient le mot Junior, ça marche pas

Je vous joint un fichier pour exemple
 

Pièces jointes

  • Compter valeur par mois.xlsx
    12.4 KB · Affichages: 5

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Rabeto,
Un essai en PJ avec :
1- En F1:Q1 vous avez du texte, non des dates, donc j'ai mis :
VB:
L'année en E1
F1: =DATE(E1;1;1)
G1:Q1: =MOIS.DECALER(F1;1)
Pour le global :
Code:
=SOMMEPROD(--(MOIS($B2:$B200)=MOIS(F1))*(ANNEE($B2:$B200)=$E$1)*($B2:$B200<>""))
Pour le détail :
Code:
=SOMMEPROD(--(MOIS($B$2:$B$200)=MOIS(F$1))*(ANNEE($B$2:$B$200)=$E$1)*($B$2:$B$200<>"")*(GAUCHE($C$2:$C$200;6)=GAUCHE($E3;6))*1)

( J'ai utilisé l'année pour les calculs pour éviter de compter 2022 et 2023. Si ce n'est pas désiré il suffit de supprimer les termes du genre (ANNEE($B$2:$B$200)=$E$1), dans ce cas il ne tiendra pas compte de l'année )
 

Pièces jointes

  • Compter valeur par mois.xlsx
    11.8 KB · Affichages: 5

Discussions similaires

Statistiques des forums

Discussions
313 209
Messages
2 096 240
Membres
106 541
dernier inscrit
edf