Microsoft 365 Sommeprod quand un champ est vide

eric72

XLDnaute Accro
Bonjour à tous,
Je cherche la possibilité de compter le nombre d'occurence pour multiples critères avec une subtilité qui est que, quand je ne sélectionne pas de nom le résultat soit pour l'ensemble de la ville, et que, quand je ne sélectionne pas de ville, le résultat soit juste le nombre d'occurences des mois sélectionnés et apparemment sommeprod n'aime pas les champs vides!!!
Voilà ma formule qui marche très bien quand tous les champs sont remplis:
VB:
SIERREUR(SOMMEPROD(
(($E$5<>"")*(TbPropo[Ville EC]=$E$5))*
(($E$7<>"")*(TbPropo[Colonne1]=$E$7))*
(MOIS(TbPropo[Date Propo])=MOIS($A12))*
(ANNEE(TbPropo[Date Propo])=ANNEE($B$3)));"")
Merci par avance pour votre aide précieuse.
Eric
 

Pièces jointes

  • test filtre2.xlsm.xlsx
    29.9 KB · Affichages: 4
Solution
Bonjour,
Essaie :
VB:
=SIERREUR(SOMMEPROD(
(SI($E$5="";1;TbPropo[Ville EC]=$E$5))*
(SI($E$7="";1;TbPropo[Colonne1]=$E$7))*
(MOIS(TbPropo[Date Propo])=MOIS($A12))*
(ANNEE(TbPropo[Date Propo])=ANNEE($B$3)));"")
Avec Excel 365 en validation normale, sinon validation matricielle par Ctrl+Maj+Entrée
Cordialement

ALS35

XLDnaute Occasionnel
Bonjour,
Essaie :
VB:
=SIERREUR(SOMMEPROD(
(SI($E$5="";1;TbPropo[Ville EC]=$E$5))*
(SI($E$7="";1;TbPropo[Colonne1]=$E$7))*
(MOIS(TbPropo[Date Propo])=MOIS($A12))*
(ANNEE(TbPropo[Date Propo])=ANNEE($B$3)));"")
Avec Excel 365 en validation normale, sinon validation matricielle par Ctrl+Maj+Entrée
Cordialement
 

eric72

XLDnaute Accro
Bonjour,
Essaie :
VB:
=SIERREUR(SOMMEPROD(
(SI($E$5="";1;TbPropo[Ville EC]=$E$5))*
(SI($E$7="";1;TbPropo[Colonne1]=$E$7))*
(MOIS(TbPropo[Date Propo])=MOIS($A12))*
(ANNEE(TbPropo[Date Propo])=ANNEE($B$3)));"")
Avec Excel 365 en validation normale, sinon validation matricielle par Ctrl+Maj+Entrée
Cordialement
Bonjour ALS35,
Merci pour la réponse, en effet il me manquait cette subtilité
VB:
(SI($E$5="";1;
J'aurais pu chercher longtemps sans votre aide.
Merci beaucoup et bonne soirée
Cordialement. 🙏
 

Discussions similaires

Réponses
1
Affichages
1 K

Statistiques des forums

Discussions
313 193
Messages
2 096 080
Membres
106 490
dernier inscrit
fabintou