comment actualiser le jour de la semaine (lu, ma...) en fonction du mois en cours ?

anthoYS

XLDnaute Barbatruc
bonjour,


je souhaite réaliser un tableau récapitulatif avec des chiffres distincts selon les mois.

Le but étant d'automatiser la mise à jour des jours selon les mois, en figeant le jour en chiffres (1, 2, 3...).

Car, ces données seront récupérés sur un autre fichier qui récapituleras le tout.

Pour plus de précision voir le fichier, avec ce qui est attendu dans un onglet éponyme.


Merci
à+
 

Pièces jointes

  • 78429610.xlsx
    173.5 KB · Affichages: 76

job75

XLDnaute Barbatruc
Re : comment actualiser le jour de la semaine (lu, ma...) en fonction du mois en cour

Bonjour anthoYs,

A priori formule en A3 à tirer vers le bas :

Code:
=TEXTE(C$1+B3-1;"jjj")
voir aussi, si nécessaire :

Code:
=SI(B3="";"";TEXTE(C$1+B3-1;"jjj"))
A+
 

Dugenou

XLDnaute Barbatruc
Re : comment actualiser le jour de la semaine (lu, ma...) en fonction du mois en cour

Bonjour Anthoys, R@chid, Job75,
une autre solution : en A3 : =$C$1-1+B3, format cellule personnalisé : jjj
Cependant cela met 3 lettres partout et pas 2 sauf pour le jeudi comme dans ton exemple.
Pour deux lettres partout i faudrait faire gauche(formule de job;2)
Cordialement
 

job75

XLDnaute Barbatruc
Re : comment actualiser le jour de la semaine (lu, ma...) en fonction du mois en cour

Re, salut R@chid, Dugenou,

En complément de mon post #3 pour A3 (2ème formule) vous pouvez de plus entrer en B3 :

Code:
=SI(B2<JOUR(DATE(ANNEE(C$1);MOIS(C$1)+1;0));B2+1;"")
B2 restant toujours vide, sinon le remplacer par N(B2).

A+
 

Discussions similaires

Statistiques des forums

Discussions
312 801
Messages
2 092 245
Membres
105 314
dernier inscrit
SABER ABD