chercher une chaine de caracètres à différents endroits

pancaspremium

XLDnaute Occasionnel
bjr
j'aimerai savoir s'il y à moyen d'avoir une formule dans les colonnes o,p,q
qui recherche des chaines de caractères à savoir que si l'on regarde dans le fichier annexé
colonne o: si l'on trouve ann* dans colonne I K L M alors chiffre 1 sinon 0
colonne p: si l'on trouve ext* dans colonne I K L M alors chiffre 1 sinon 0
colonne q: si l'on trouve canc* dans colonne I K L M alors chiffre 1 sinon 0

le "*" sert limiter le mot
pas évident d'expliquer mon souhait compliqué

merci à toute aide car je suis perdu .....
MERCI
 

Pièces jointes

  • nos.xls
    383 KB · Affichages: 84

pancaspremium

XLDnaute Occasionnel
Re : chercher une chaine de caracètres à différents endroits

bjr
merci pour ton retour
mais dans ta formule on ne trouve rien qui recherche la chaine de caractères
colonne o: si l'on trouve ann* dans colonne I K L M alors chiffre 1 sinon 0
colonne p: si l'on trouve ext* dans colonne I K L M alors chiffre 1 sinon 0
colonne q: si l'on trouve canc* dans colonne I K L M alors chiffre 1 sinon 0
 

phlaurent55

Nous a quittés en 2020
Repose en paix
Re : chercher une chaine de caracètres à différents endroits

Bonjour à tous,

avec cette formule en O2 (à recopier vers le bas et vers la droite)
Code:
=SI(ESTNUM(CHERCHE(O$1;MAJUSCULE(CONCATENER($I2;$J2;$K2;$L2;$M2));1));1;0)


à+
Philippe
 

Discussions similaires

Réponses
8
Affichages
509
Réponses
5
Affichages
274
Réponses
7
Affichages
392

Statistiques des forums

Discussions
312 897
Messages
2 093 392
Membres
105 718
dernier inscrit
Kro