XL 2016 Montant à calculer en fonction d'une date et création d'un fichier avec quelques colonnes du fichier initial

vivi21

XLDnaute Occasionnel
Bonjour,

J'ai un fichier (voir exemple ci-joint).
Sur ce fichier, je veux ajouter une colonne (entre L et M) dans cette colonne je souhaite obtenir un montant qui sera déterminé par la date d'inscription (colonne E) et la date du 16 septembre 2023 minuit. Si la date d'inscription est antérieur au 16/09 alors le montant sera de 500 * nombre de participants (colonne AQ) sinon le montant sera de 650 * nombre de participants.

Ensuite j'ai besoin de récupérer uniquement les colonnes A,E,F,I,J,K,P, AA,AB,AC,AD pour avoir un nouveau fichier.

J'aimerais avoir 2 étapes avec 2 macros.

Merci pour votre aide toujours si précieuse.

Vivi
 

Pièces jointes

  • exemple_vivi.xlsx
    14.4 KB · Affichages: 3

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Vivi,
En PJ un essai fait de façon un peu différent;
Pour le montant, en M2 :
VB:
=SI(E2<="16/09/2023";500*AR2;650*AR2)
Ensuite, plutôt que de dupliquer les données, on peut simplement masquer démasquer les colonnes.
Pour cela faire ALT+F8 puis choisir l'action à effectuer Masquer ou Démasquer. Avec ces macros :
Code:
Sub Masquer()
    Application.ScreenUpdating = False
    Range("B:D, F:H, L:P, R:AA, AF:AQ").EntireColumn.Hidden = True
End Sub
Sub Démasquer()
    Application.ScreenUpdating = False
    Range("B:D, F:H, L:P, R:AA, AF:AQ").EntireColumn.Hidden = False
End Sub
 

Pièces jointes

  • exemple_vivi.xlsm
    14.7 KB · Affichages: 4

Discussions similaires

Membres actuellement en ligne

Aucun membre en ligne actuellement.

Statistiques des forums

Discussions
313 271
Messages
2 096 724
Membres
106 720
dernier inscrit
Alain EDZOA