XL 2016 Calcul nbre de jours consécutifs travaillés

anso13

XLDnaute Nouveau
Bonjour à tous,

Je cherche a regarder si les salariés d'une entreprise ne travaillent pas plus de 7 jours consécutifs.
J'ai un fichier avec le matricule du salarié en colonne 1 et les dates travaillées en colonne 2.

Pourriez vous m'aider a ajouter a mon fichier:
1 colonne avec le nombre de jours consécutifs travaillés
1 colonne avec une alerte quand le nombre de jours travaillés est supérieur a 7.

J'ai créé une Maquette manuelle de ce que je veux reconstituer en mode Automatique (fichier joint).

Merci a tous ceux qui auront la gentillesse de m'aider car je sèche sur cette demande que l on vient de me formuler.

ASO
 

Pièces jointes

  • Calcul Alerte sur nbre de jours travailles consecutifs.xlsx
    9.4 KB · Affichages: 10

TooFatBoy

XLDnaute Barbatruc
Bonjour,

Pour calculer le nombre de jours consécutifs, je te propose la formule suivante à mettre en C2 et à tirer vers le bas :
Code:
=SI(ET(A2=A1;B2=SOMME(B1;1));SOMME(C1;1);1)

Pour l'alerte, je te propose la formule suivant à mettre en D2 et à tirer vers le bas :
Code:
=SI(C2>6;"/!\   ALERTE   /!\";"")
 
Dernière édition:

Discussions similaires

Statistiques des forums

Discussions
312 922
Messages
2 093 644
Membres
105 775
dernier inscrit
assen