Sommer des comptes en fonction de la période

ACH

XLDnaute Nouveau
Bonjour,

J’ai un problème dans ma formule. J’essaie de développer un petit outil qui me permet de faire la somme des comptes pour une période sélectionnée. Pour plus de clarté, je joins le fichier exemple ; la formule se trouve dans la cellule D6 de l'onglet "Bilan". Je trouve la formule trop lourde. Si vous avez d'autres solutions à me proposer, je suis preneur.


Merci d'avance pour vos réponses,


ACH
 

Pièces jointes

  • balance ajustable essai.xls
    495.5 KB · Affichages: 91

mdo100

XLDnaute Occasionnel
Bonjour ACH, toutes et tous,

En ajoutant une colonne "A" feuille "Liste des comptes", puis en appliquant la formule qui va bien en feuille "Bilan" cellule "D5, D6 etc..."

Voir si cela convient.

Cordialement.
 

Pièces jointes

  • balance ajustable essai V1.xlsx
    172.1 KB · Affichages: 82

vgendron

XLDnaute Barbatruc
Hello
pas sur d'avoir compris le besoin..
en D5 tu souhaites la somme des comptes dont le numéro commence par 22 (cellule C5) pour le mois sélectionné en D3??
et en D6, ceux dont le numéro commence par 23
dans ce cas..

en D5
Code:
=SOMMEPROD((C5=GAUCHE('Liste des comptes'!$A$2:$A$32;2))*('Liste des comptes'!$C$1:$D$1=Bilan!$D$3)*('Liste des comptes'!$C$2:$D$32))
et tu tires vers le bas
 

Discussions similaires

Réponses
10
Affichages
359

Membres actuellement en ligne

Aucun membre en ligne actuellement.

Statistiques des forums

Discussions
312 827
Messages
2 092 557
Membres
105 451
dernier inscrit
mariane_lp