somme si compris entre un interval

atfcrew

XLDnaute Junior
salut, je voudrais faire une somme de cellules si un chiffre compri dans un tableau est compris dans un intervalle par exmple:

additionner lignes: A1:A10, si les chiffres compris dans la colonne A, sont inclus dans l'intervalle 1; 20
merci
 

Tibo

XLDnaute Barbatruc
Re : somme si compris entre un interval

re,

bah non, car comme tu dis, la fonction SOMME.SI n'accepte qu'un seul critère.

Sinon, tu peux passer par une plage nommée :

Menu Insertion - Nom - Définir

Nom = plage
Fait référence à : =DECALER(Feuil1!$A$1;;;NBVAL(Feuil1!$A:$A))

Ensuite, taper la formule suivante :

=SOMMEPROD((plage>=1)*(plage<=20)*plage)

Avec la plage nommée, ta formule s'adapte automatiquement au nombre de données de ta colonne A

@+
 

victorieta

XLDnaute Nouveau
Re : somme si compris entre un interval

hello, je relance le topic... je tente d'appliquer la formule somme.prod mais la cellule renvoit "NOM?" comme erreur, je rentre la formule suivante:

=SOMME.PROD((C4:C131>=300)*(C4:C131<=1000)*C4:C131)

je souhaite avoir la somme de toutes les cellules comprises entre C4 et C131 dont le contenu est entre 300 et 1000.....

Merci!
 

Brigitte

XLDnaute Barbatruc
Re : somme si compris entre un interval

Bonjour,

Aurais tu un bout de fichier à nous soumettre (zippé, sans donnée confidentielle, moins de 50 Ko, et avec un nom sans caractère spécial ni espace) ???

Sinon, une petite piste : tes chiffres en colonne C sont ils des chiffres (format numérique) ou résultent ils d'une concaténation ou autre chose qui ferait qu'ils sont au format texte ?
Pour le voir, sélectionne les et fais FORMAT/Cellule, vérifie le format (numérique ou texte) ?

Car parfois, on voit des chiffres mais ce ne sont pas vraiment des chiffres...

Si texte, il faut faire une colonne intermédiaire, dans laquelle tu tapes :

=Cnum(C1) et tu recopies vers le bas

Puis tu copies cette colonne créée, tu vas sur C1 et tu fais collage spécial valeur... et tu réessaies le sommeprod.

Dis nous.
 
Dernière édition:

Papag1322

XLDnaute Nouveau
Bonjour,

Je suis un peu rouillé en excel
J'ai du mal a appliquer somme.si.ens car je n'ai pas de plage mais une seule valeur.
Si qqun peut m'aider?

Dans B1 j'ai une valeur X
Dans B2 je dois avoir 169<Y<186
Dans B3 je dois avoir Y>186

X représentant un nb d'heures global
Y représentant le nb d'heures compris entre

Merci par avance
 

Discussions similaires

Statistiques des forums

Discussions
299 841
Messages
1 979 473
Membres
206 744
dernier inscrit
Nicolas258