XL 2016 Somme en fonction des critères

Rabeto

XLDnaute Occasionnel
Bonjour,

J'aimerai calculer la somme des valeurs selon les critères par colonne.
La somme pour chaque personne en fonction du mois.

J'avais une piste avec cette formule en précisant la date de début du mois et fin mois en C22 et C23 mais cela ne fonctionne pas.

=SOMME.SI.ENS(DECALER((ligne des dates) ;EQUIV((Choix agent) ; (liste agent) ;0);1;1;31);DECALER( (ligne des dates) ;0;1;1;31);">=" & (debut mois);DECALER( (ligne des dates) ;0;1;1;31);"<=" & (Fin mois))

Cordialement,
 

Pièces jointes

  • Somme.xlsx
    11.9 KB · Affichages: 9

Rabeto

XLDnaute Occasionnel
Bonjour JHA,

En un fichier, il y a pas mal de nouvelle chose que je savais même pas que ça existe,
C'est trop TOP, je vais adapter mon fichier selon ta réponse,

Il y a juste une dernière demande, possible de mettre ceux en gras avec les colonnes ou lignes à selectionner, sinon, en même temps, je vais voir comment je me débrouille en les remplaçant.

=SOMME(TRANSPOSE(DECALER($B$3;EQUIV($C$15;LongueurAgent;0);1;;NBVAL(LargeurPlage))*(--(MOD(COLONNE(LargeurPlage);5)=3))*(MOIS(PlageDate)=MOIS(1&$B$15))))

Merciiiii milles fois,
 

Discussions similaires

Réponses
11
Affichages
615

Statistiques des forums

Discussions
312 931
Messages
2 093 721
Membres
105 796
dernier inscrit
Max...26