résultat incompréhensible d'une formule sommeprod

alfonso

XLDnaute Junior
bonjour à tous

j'ai une formule sommeprod dont je ne comprend pas le resultat

=SOMMEPROD((Stator!$L$13:$L$1036=B67)*(Stator!$Y$13:$Y$1036>0))

en faite c'est la partie (Stator!$Y$13:$Y$1036>0) qui m'embète car dans la plage de cellule j'ai des valeurs négatif or excel me les comptes alors que je demande uniquement les valeurs positifs

est-ce que j'ai fait une erreur dans la formule ??
 

Jocelyn

XLDnaute Barbatruc
Re : résultat incompréhensible d'une formule sommeprod

Bonjour le Forum,
Bonjour alfonso,

Pour compter les valeurs a tester

=SOMMEPROD((Stator!$L$13:$L$1036=B67)*(Stator!$Y$13:$Y$1036>0)*1)

pour les additionner

=SOMMEPROD((Stator!$L$13:$L$1036=B67)*(Stator!$Y$13:$Y$1036>0)*Stator!$Y$13:$Y$1036)

si ce n'est pas ca joint un morceau de fichier sans données confidentielle

Jocelyn
 

Discussions similaires

Statistiques des forums

Discussions
312 023
Messages
2 084 713
Membres
102 637
dernier inscrit
TOTO33000