Microsoft 365 Répartir un chiffre en fonction de la date début et fin de contrat

Dinho

XLDnaute Nouveau
Hello,

Je viens solliciter votre aide, car je bloque sur un cas. j'essaie de répartir un chiffre mensuellement sur la durée du contrat. j'ai combiné plusieurs formules, mais sur certaines lignes le montant total répartit dépasse le montant initial.

Je vous joins le fichier avec mes formules.

Merci d'avance pour votre aide.:)
Dinho
 

Pièces jointes

  • Test Répartition CA.xlsx
    16.1 KB · Affichages: 11
Solution
Bonjour Dinho, job75, le forum,
Une autre proposition d'après ce que j'ai compris,
On ne sait pas s'il peut avoir un ou 2 mois partiels dans une période et ce qu'il faut faire dans ce cas !

Cordialement

job75

XLDnaute Barbatruc
Bonsoir Dinho, Amilo,

Voyez le fichier joint, le nom défini jour (qui est une matrice) et la formule en O3 :
Code:
=SOMMEPROD((jour>=$B3)*(jour<=$C3))*$K3/($C3-$B3+1)
Format personnalisé sur la plage O3:AA7 pour masquer les valeurs zéro.

A+
 

Pièces jointes

  • Test Répartition CA(1).xlsx
    15.9 KB · Affichages: 4

job75

XLDnaute Barbatruc
Bonjour Dinho, le forum,

Finalement les SOMMEPROD c'est pas bien fameux, ça prend du temps de calcul.

Utilisez plutôt cette formule bien plus simple en O3, fichier (2) :
Code:
=MAX(MIN($C3;O$1)-MAX($B3;O$1-JOUR(O$1)+1)+1;)*$K3/($C3-$B3+1)
Le 1er MAX évite les valeurs négatives.

A+
 

Pièces jointes

  • Test Répartition CA(2).xlsx
    15.7 KB · Affichages: 7

Dinho

XLDnaute Nouveau
Hello,
Merci Amilo & Job75 pour vos réponses.
j'ai un autre point. est il possible par exemple sur la 1ère ligne que le montant total ne soit que sur Avril, vu que la durée en nombre de mois est de 1?
J'ai oublié de préciser que la date fin je l'ai calculé en fonction de la durée en colonne A.
Merci pour votre aide
A+
 

Amilo

XLDnaute Accro
Bonjour Dinho, job75, le forum,
Une autre proposition d'après ce que j'ai compris,
On ne sait pas s'il peut avoir un ou 2 mois partiels dans une période et ce qu'il faut faire dans ce cas !

Cordialement
 

Pièces jointes

  • Test Répartition CA_V2.xlsx
    15.3 KB · Affichages: 6

job75

XLDnaute Barbatruc
Bonjour Dinho, Amilo,

De retour de voyage, je suis surpris par cette demande :
j'ai un autre point. est il possible par exemple sur la 1ère ligne que le montant total ne soit que sur Avril, vu que la durée en nombre de mois est de 1?
J'ai oublié de préciser que la date fin je l'ai calculé en fonction de la durée en colonne A.
Cela n'a pas grand sens, si l'on veut que la date de fin ne soit pas le 1er du mois mais le dernier jour du mois précédent corrigez-la, un point c'est tout, voyez ce fichier (3).

A+
 

Pièces jointes

  • Test Répartition CA(3).xlsx
    15.7 KB · Affichages: 4

Discussions similaires

Statistiques des forums

Discussions
299 878
Messages
1 979 751
Membres
206 857
dernier inscrit
Pageee