XL 2013 récupérer les dates dans une chaine (formule excel)

patricktoulon

XLDnaute Barbatruc
Bonjour à tous
je vais commencer a me faire un recueil d'exemple de formule excel pour le texte

aujourd'hui je cherche une formule qui pourrait me donner la Nieme( de 1 à x) date dans une chaine
à l'heure actuelle j'ai la première simplement avec STXT ET CHERCHE
=STXT(A1;CHERCHE("??/??/????";A1;1);10)
j'aimerais trouver une formule qui me permette d'avoir la 2d , la 3eme etc...
 

job75

XLDnaute Barbatruc
Bon voici la formule qui remédie aux 2 remarques :
Code:
=STXT(A2;PETITE.VALEUR(SI(ESTNUM(DATEVAL(STXT(SUBSTITUE(A2;" ";"x");LIGNE(INDIRECT("1:"&NBCAR(A2)));10)));LIGNE(INDIRECT("1:"&NBCAR(A2))));A6);10)
SUBSTITUE remplace les espaces par des "x" uniquement dans le test.
 

Pièces jointes

  • Extraction nième Date(2).xlsx
    10.9 KB · Affichages: 1

patricktoulon

XLDnaute Barbatruc
Bon ben là je crois que l'on a tout bon
formule adoptée la N° de @job75 + Gestion d'erreur + auto incrémentation verticale
Code:
=SIERREUR(STXT(A$10;PETITE.VALEUR(SI(ESTNUM(DATEVAL(STXT(SUBSTITUE(A$10;" ";"x");LIGNE(INDIRECT("1:"&NBCAR(A$10)));10)));LIGNE(INDIRECT("1:"&NBCAR(A$10))));LIGNE(1:1));10);"-")
1708863387379.png
je joins le fichier
 

Pièces jointes

  • exemple final.xlsx
    11.8 KB · Affichages: 4

Discussions similaires

Statistiques des forums

Discussions
313 296
Messages
2 096 922
Membres
106 787
dernier inscrit
Rachid ALIOU