probleme de formule

M

mimi

Guest
bonjour
comment calculer une somme entre 2 dates que je desire
je vous donne un exemple un commercant dans le mois voudrez savoir le chiffre qu'il a fait entre 2 dates données supposant entre 1/01/2005 et le 06/01/2005 ou bien entre 5/01/2005 et 15/01/2005
colonne A les jours du mois 1/1/2005 au 30/01/2005
colonne B le chiffre d'affaire qu'il a fait

colonne C3 date de debut
colonne C4 date de fin
colonne C5 montant
Formule en C5 =SOMME(B1:B30*(A1:A30>=C3)*(A1:A30<=C4))

je n'arrive pas
merci d'avance
 
M

mimi

Guest
non ta formule ne marche pas ci joint le fichier [file name=essai_20051023121948.zip size=1731]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/essai_20051023121948.zip[/file]
 

Pièces jointes

  • essai_20051023121948.zip
    1.7 KB · Affichages: 14
M

mimi

Guest
le fichier que j'ai joint precedemment n'est pas le bon je joint
le bon [file name=essai_20051023122607.zip size=1634]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/essai_20051023122607.zip[/file]
 

Pièces jointes

  • essai_20051023122607.zip
    1.6 KB · Affichages: 13

dg62

XLDnaute Barbatruc
Bonjour mimi, André, le Forum



une question !


pourquoi,


cette formule fonctionne

=SOMME.SI(A2:A32;'>=12/01/2005';B2:B32)-SOMME.SI(A2:A32;'>=22/01/2005';B2:B32)

et celle ci non ?

=SOMME.SI(A2:A32;'>=c3';B2:B32)-SOMME.SI(A2:A32;'>=c4';B2:B32)

en c3 12/01/2005 et en c4 22/01/2005

Message édité par: dg62, à: 23/10/2005 12:44
 

Monique

Nous a quitté
Repose en paix
Bonjour,

Celle-ci fonctionne :
=SOMMEPROD((A1:A31>=C1)*(A1:A31<=C2);B1:B31)

Celle que tu as mise en C3 fonctionne aussi,
mais il faut la valider en appuyant simultanément sur ctrl, maj et entrée
=SOMME(B1:B31*(A1:A31>=C1)*(A1:A31<=C2))
 

Discussions similaires

Réponses
3
Affichages
334

Statistiques des forums

Discussions
312 927
Messages
2 093 674
Membres
105 781
dernier inscrit
Dominique G.