XL 2019 Calculer la somme de plusieurs dates personnalisés (00A00M17J)

HE_RA

XLDnaute Nouveau
Bonjour à tous,

Je voudrais additionner la colonne des durées des services (somme totale) et je n'ai pas trouver la fonction pour résoudre mon problème.
Voici la formule qui m'a permis de calculer la durée des services sous ce format 00A00M17J sur la ligne 26 jusqu'à la ligne 33 :
=SI(OU(G26="";H26="");"";TEXTE(DATEDIF(G26;H26+1;"Y");"00\A")&TEXTE(DATEDIF(G26;H26+1;"YM");"00\M")&TEXTE(DATEDIF(G26;H26+1;"MD");"00\J"))
DuAuTC
ou TNC
Durée des services
AN, MOIS, JOUR
14/02/0302/03/03TC00A00M17J
20/08/0417/11/04TC00A02M29J
18/11/0403/12/04TNC 50%00A00M16J
04/12/0419/12/04TNC 50%00A00M16J
01/09/0513/08/06TC00A11M13J
14/08/0631/08/06TC00A00M18J
01/09/0607/08/16TC09A11M07J
08/08/1620/09/23TC07A01M13J
Total des services??A??M??J

Pourriez-vous solutionner mon problème SVP?

Merci d'avance de votre retour.
HERA
 

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Hera,Fanfan,
Un essai en PJ avec :
1-Total des services (A11) qui donne le total des durées en jours :
VB:
=SI(OU(A3:A10="";B3:B10="");"";SOMME(B3:B10-A3:A10))  A valider en matriciel
2- La durée en D11:
Code:
=SI(A11=0;"";TEXTE(DATEDIF(0;A11;"Y");"00\A")&TEXTE(DATEDIF(0;A11;"YM");"00\M")&TEXTE(DATEDIF(0;A11;"MD");"00\J"))
 

Pièces jointes

  • HERA.xlsx
    10.1 KB · Affichages: 4
Dernière édition:

Discussions similaires

Réponses
2
Affichages
551