XL 2016 Extraire plusieurs valeurs avec formule

dieselovitch

XLDnaute Nouveau
Bonjour,

J'ai un petit soucis avec un fichier que je suis en train de construire. J'ai une feuille exploitation et une feuille STO composée de plusieurs colonnes les colonnes qui m'intéresse sont la A = Reference la C = quantité la D = Date et B = numéro de commande. Dans ma Feuille Exploitation j'ai les dates de toutes les semaines compilées en 7 jours entre la ligne 8 et 14 par exemple : B8 = 08/01/2023 et B14 (premier jour de la semaine) = 02/01/2023 , I14 = 20/02/2023 et I8=26/02/2023.

Ensuite j'ai une ligne STO ligne 17 de ma feuille Exploitation. Dans cette ligne il y a certaines semaine (correspond au plage précédemment citées) où j'ai des quantités exemple pour la colonne N (plage de B8 = 02/04/2023 et B14 = 27/03/2023) j'ai 2000. Ce que je souhaite c'est pouvoir insérer une formule en B18 que je vais tirer sur toute l'année.

Cette formule va chercher ma référence cellule C4 (correspondant a la colonne A dans la feuille STO) ainsi que toute les dates de ma plage de cellule (celles correspondantes a la plage B8 à B14 et correspondant a la colonne F dans ma feuille STO) dans la feuille STO et me récupérer le numéro de commande (colonne C dans ma feuille STO) correspondant.

Attention dans ma feuille STO j'ai plusieurs fois la même référence. Si une référence à plusieurs fois la meme date (dans la colonne F) la formule doit etre capable de m'écrire les différents numéros de commande => s’il y en a qu'un uniquement en mettre un seul.

J'ai essayé cette formule qui ne fonctionne pas (voir cellule B18) =SIERREUR(SI(B17=0;"";SIERREUR(INDEX(STO!$B$2:$B$1000;MODE.MULT(IF((STO!$A$2:$A$1000=$C$4)*(STO!$D$2:$D$1000>=B$8)*(STO!$D$2:$D$1000<=B$14)*(STO!$C$2:$C$1000<>0);EQUIV(STO!$D$2:$D$1000;STO!$D$2:$D$1000;0)));"");"Aucun numéro de commande trouvé"));"ERREUR")

Merci à vous !
 

Pièces jointes

  • test.xlsx
    704 KB · Affichages: 19

njhub

XLDnaute Occasionnel
Bonjour dieselovitch,

Excel est il paramétré en français ou en anglais?

Vous utilisez les deux langues dans la même formule...
Code:
[SI(B17=0;"";SIERREUR(INDEX(STO!$B$2:$B$1000;MODE.MULT(IF(]
Avec equiv vous cherchez l'intégralité de la colonne
Code:
[EQUIV(STO!$D$2:$D$1000;STO!$D$2:$D$1000;0)]
dans cette même colonne..?

Difficile à résoudre...
 

Discussions similaires

Réponses
10
Affichages
314

Statistiques des forums

Discussions
312 820
Messages
2 092 410
Membres
105 410
dernier inscrit
TahYou-K3n