Problème de Formule

MISTERJUNGLE

XLDnaute Occasionnel
Bonjour, le Forum
j'ai un souci avec une formule. je m'explique : sur 1 journée de 13h45 , il faut que je comptabilise_1h00 de 12 a 13 a 75% __et 00h45 a 100%
ma formule fonctionne en "P 315" jusqu’a "S 315" mais quand je la tire vers le bas elle ne fonctionne plus
merci pour votre aide
 

Pièces jointes

  • TEST IDAJ.xlsm
    464.4 KB · Affichages: 50

MISTERJUNGLE

XLDnaute Occasionnel
Bonjour CISCO, et le Forum
merci pour la formule, mais je pense apporter quelque mise a jour pour que cela fonctionne

si le nombre d'heure en "K315" est " = " ou " < " a 12H00 "P315" est égal a 00H00

si le nombre d'heure en "K315" est "=" a 13H00 "P315" est égal a 01H00

si le nombre d'heure en "K315" est " > " a 13H00 "P315" est égal a 01H00 et "R315" la différence

merci d'avance pour votre aide
 

Pièces jointes

  • TEST IDAJ.xlsm
    454.7 KB · Affichages: 34

CISCO

XLDnaute Barbatruc
Bonjour

La formule que tu utilises te renvoie SOMMEPROD({1;1;1;1;1}*0:15) = 5 * 0:15 = 1:15. Pour voir cela, passe par "Formules", puis par "Évaluation de formule".

Pour obtenir ce que tu veux, tu pourras peut être faire avec
Code:
SOMMEPROD((SOMMEPROD(CHERCHE($CD$1:$CD$5;H317))>0)*SI(K317>$B$2;K317-$B$2)*SI(K317<=$B$2;$F$2*1/2;1))

ou encore avec
Code:
SOMMEPROD((OU(CHERCHE($CD$1:$CD$5;H317))*SI(K317>$B$2;K317-$B$2)*SI(K317<=$B$2;$F$2*1/2;1)))
cette dernière en matriciel, donc à valider avec les 3 touches Ctrl+maj+entrer.


@ plus
 

CISCO

XLDnaute Barbatruc
Bonjour

Je ne sais pas ce que tu veux faire exactement dans cette colonne P, mais n'y aurait-il pas une petite erreur, une parenthèse mal placée : Dans la partie ESTNUM(CHERCHE($V$1:$V$5;H319>0)), à quoi sert le H319 > 0 ?

@ plus
 

MISTERJUNGLE

XLDnaute Occasionnel
Bonjour CISCO,
je te remercie pour ton aide cela fait plaisir, j'ai trouvé de l'aide et cela fonctionne
je me suis un peu perdu dans mes formules a force de bidouiller
voila la formule : =SI(K17>0,5;MIN(K17-0,5;1/24);0) en colonne " P "
et =SI(K17>13/24;K17-13/24;0) en colonne "S"
je pense m’être mal exprimé toutes mes excuses et encore un GRAND MERCI
 

Discussions similaires

Statistiques des forums

Discussions
312 890
Messages
2 093 349
Membres
105 696
dernier inscrit
FrancisR