Problème avec organigramme H

erics83

XLDnaute Impliqué
Bonjour,

Je cherche à faire des organigramme de manière rapide et simple.
Je suis allé sur le blog de JB et j'ai trouvé mon bonheur avec l'exemple organigrammeH.xls dans le domaine de la récursivité, mais j'ai un souci : cela ne donne pas le résultat voulu.... :
Le résultat que l'on devrait obtenir (suivant ce qui est mis sur le blog):

upload_2017-2-15_22-29-10.png


et lorsque je clique simplement sur le bouton (=je ne modifie pas le code, je ne fais que le faire "tourner"), j'obtiens :
upload_2017-2-15_22-31-8.png

et je ne sais d'où cela vient....(je suis sur E2007)...J'ai bien une petite idée qui serait des incompatibilités entre versions Excel, mais...il doit bien y avoir une solution....

Une petite aide ?

En vous remerciant par avance,
Eric
 
Dernière édition:

erics83

XLDnaute Impliqué
Merci Roland_M,

Quand vous dites "ça fonctionne bien ainsi", cela veut dire que vous obtenez le schéma N°1 de mon post ? (je pose la question car je n'ai pas compris votre deuxième phrase)

En vous remerciant,
 
Dernière édition:

Roland_M

XLDnaute Barbatruc
Bonjour,

effectivement ce n'est pas très clair, il était temps que j'aille me coucher .

donc "ça fonctionne bien ainsi" c'est à dire le schéma qui semble ne pas convenir
celui qui est en dessous de celui que vous souhaitez ! "Le résultat que l'on devrait obtenir"

et quand je dis "Je n'ai jamais très bien compris non plus"
c'est le résultat de la macro que je ne comprend pas non plus, le placement !?

je l'aurai plutôt vu aussi comme celui que vous souhaitez, celui d'en haut, car il semble visuellement plus logique.
 
Dernière édition:

Discussions similaires

Réponses
6
Affichages
366
Réponses
8
Affichages
346

Statistiques des forums

Discussions
312 927
Messages
2 093 674
Membres
105 781
dernier inscrit
Dominique G.