XL 2021 Classement avec ex aequo parfait

Jul1en

XLDnaute Nouveau
Bonjour,

J'essaye de faire un classement avec les règles ci-dessous

Dans mon exemple ci-joint j'ai en colonne A 2 pilotes puis les résultats de chaque course en colonne B, C, D

En colonne E, j'ai effectué la moyenne des résultats de chaque pilote en leur ajoutant la 1ère plus petite valeur/1000, la 2ème plus petite valeur/10000 et la 3ème plus petite valeur/100000

Malheureusement dans ce cas, au vu des résultats, ça ne les départage pas et j'obtiens un ex aequo parfait

La règle dit dans cette situation que c'est le 1er meilleur résultat qui est devant

Dans ce cas B a été 8ème avant A du coup il se positionne devant au classement

Est il possible de réaliser cela ?

Merci d'avance pour votre aide
 

Pièces jointes

  • Exemple.xlsx
    10.2 KB · Affichages: 5

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Ju1lien,
Peut être une piste en PJ avec :
VB:
=MOYENNE(B2:D2)+LIGNE()/10000000
Le terme Ligne()/1000000 permet de départager les ex aequo.
et pour le classement :
Code:
=INDEX($A$2:$A$6;EQUIV(GRANDE.VALEUR($E$2:$E$6;G2);$E$2:$E$6;0))
 

Pièces jointes

  • Exemple.xlsx
    9.9 KB · Affichages: 6

ALS35

XLDnaute Occasionnel
Bonjour,
On peut ajouter une petite correction dépendant de la position de la colonne du meilleur résultat, par exemple en E2 :
VB:
=MOYENNE(B2:D2)+EQUIV(MIN(B2:D2);B2:D2;0)/100
Cordialement
 
Dernière édition:

Jul1en

XLDnaute Nouveau
Merci pour vos propositions
Sylvanu : ça ne répond pas à la règle car dans cette situation c'est le 1er meilleur résultat qui est classé devant
ALS35 : J'ai trouvé une autre proposition mais qui ressemble
VB:
+EQUIV(MIN(B2:D2);B2:D2;0)/1000000)
 
Dernière édition:

Discussions similaires

Réponses
4
Affichages
437
Réponses
18
Affichages
986