XL 2016 Problème avec la fonction recherchev

dodeee

XLDnaute Nouveau
Bonjour à tous,

J'ai un soucis avec ma fonction recherchev.
Je vous joints le fichier "test" en PJ.

Mon "vrai" fichier fait 950 lignes et ma fonction recherchev ne fonctionne pas. J'ai passé plusieurs heures à chercher sur des forums etc, certains parlent d'une différence de format de cellule, ou encore d'espace avant le champs... j'ai vérifié, ce n'est pas ca.

En colonne A, une date de Bon de livraison associé a un numéro de commande (colonne B).
En colonne E, un numéro de commande (issu d'un autre fichier) à qui je dois attitrer un numéro de BL. (En gros, si la référence en E est trouvée dans la colonne B, alors il faut inscrire le champs que l'on trouve en A.
= recherchev(E2;$A$2:$B$922;1;FAUX), mais cela ne fonctionne pas...j'ai en solution #N/A. Je ne m'en sors pas...

Si qq'un pouvait m'aider, ce serait top :)

Un grand merci d'avance
 

Pièces jointes

  • export cegid commande ACF.xls
    496.5 KB · Affichages: 41

thebenoit59

XLDnaute Accro
Bonjour dodeee.

La fonction RechercheV ne permets pas de rechercher sur la colonne précédente.
Il faut utiliser la combinaison Index et Equiv, essaye la formule ci-dessous en F.
Code:
=SIERREUR(INDEX($A$2:$B$922;EQUIV(E2;$B$2:$B$922;0);1);"Pas de date de BL")
 

Jocelyn

XLDnaute Barbatruc
Bonjour le Forum,
Bonjour dodeee,

Pour que ta rechercheV fonctionne il faudrait que tes colonne A et B soient inversées, en l'état Recherchev ne peux pas fonctionner par conntre tu peux utiliser cette formule en F2

Code:
=INDEX($A$2:$A$922;EQUIV(E2;$B$2:$B$922;0))

Cordialement

EDIT Bonjour thebenoit59, désolé pour la collision
 

dodeee

XLDnaute Nouveau
Je me suis trompée... sorry !!
En réalité, ce n'est pas la date de BL que je souhaite avoir, mais le numéro de BL.
En feuille 1, date BL, num BL et num commande.
En feuille 2, num commande, date BL avec votre formule et il manque le numéro de BL..
 

Pièces jointes

  • export cegid commande ACF.xls
    604 KB · Affichages: 37

Discussions similaires

Réponses
3
Affichages
253

Statistiques des forums

Discussions
312 842
Messages
2 092 740
Membres
105 519
dernier inscrit
faivre-roussel.ivan@orang